Blender Connector fail

We made some changes to the installer to make it cross connector and more stable. Let me know if following steps solves your issue:

  • Uninstall Blender connector
  • Manually remove “modules” folder from this path👉: C:\Users\user_name\AppData\Roaming\Blender Foundation\Blender\blender_version\scripts\addons
  • Install Blender 2.11.1 via Manager.
1 Like

I tried your steps in Blender 3.5 Alpha and 3.4.1.
A few times, even with restarting Blender between AddOn deactivating and uninstall,
and after new installation.

But it did not work, I am still missing my total count of children :slight_smile:
I will send you a DM with link to my Test Stream.

1 Like

hey @zoomer,

Got your file. We’re looking into it. I’ll let you know once we have a solution.

1 Like

Great :slight_smile:

I will also test the same geometry exported from Bricscad as IFC 4.0 and IFC 3x2 later.

(Blender BIM liked it)

Hello there, I’m going to explain another solution for Mac users. I hope this approach can help you all too. In addition, I’d like to add that the Speckle team is working on UX improvements regarding the connector upgrades.

So, the steps I followed were:

  1. Uninstall blender plugin from Manager.
  2. Open Finder > Go > Library (you need to push option key to see it) > Application Support > Blender > [blender_version] > scripts > addons > modules
  3. I removed specklepy and specklepy-version.dist-info folders (or all relative Speckle’s folders)
  4. This step maybe is not mandatory, but just in case I did. I move the whole modules folders into another place (documents, desktop,… up to you).
  5. I reinstalled the Blender plugin from Manager.
  6. Open Blender now and go to Edit > Preferences and search for the Speckle plugin and activate it.

PRO TIP: Currently the Speckle tab in Blender is only shown in Object mode, so be sure to switch to that if you are in Edit mode.

blender plugin mac

1 Like

This is still a good tip if you had problems installing Blender Connectors before.
And you should do this cleanup for all your Blender Installation’s Settings.

Manual cleanup is also necessary for e.g. BlenderBIM AddOn.
As long as there are rests of older BlenderBIM installation, installing a new
version will fail.
And for upgrading, always follow :

  1. Deactivate BlenderBIM first
  2. Shut down and restart Blender
  3. only then “uninstall” BlenderBIM in Addons
    Otherwise it can not delete all files in Blender’s AddOn Folder in Blender’s Settings
    and your upgrade will fail.

But for installing Blender Connector by Speckle Manager on M1 Mac,
the last few Updates from Speckle work reliable for me here.

Speckle will install or update Speckle AddOn successfully in ALL (!)
Blender installation’s Settings Folders.
(even for a latest 3.5 Alpha Blender)

But I am not sure if that also works for Intel Macs.
AFAIR, when latest testing my Trash Can with Monterey, installation from
Manager did not work, Blender AddOn Folders stayed empty.
But not 100% sure.

Yes, please give me a hint that I don’t forget.

After there were a few updates in recent days, I tried receiving again, but still unsuccessfully.

And as you may have noticed, I also just uploaded the same IFC again,
if I got that right that is the recommended way to “update” the content of a Stream.
(Not deleting the whole Stream and create a new one - as I did so far)
But I am still a bit overwhelmed by the Commit/History part of Speckle …

But that did also not help to find the"total number of children" :slight_smile:

We have an early fix for the “total number of children” error already on our beta tester server (let me know if you’d like an invite :wink:)

When it passes our internal testing, it will make its way to


No hurry,
I just want to miss it :slight_smile:

On the other hand,
what I currently did by activating Betas in Manager is just the local part,
like Beta Managers and access to Connector Betas ?

So it would be a completely different/separate Server (?) looking basically
the same, just with pre release server stuff running for testing (?)
would make my humble unreleased testing more complete ?

Hope I will manage the twin Setup,
but Yes, I would like to get an invitation :blush:

1 Like

Yes, exactly. We release new “Web” features on this server first and test them there. Once testing is done, they go live on the public “” server.

That will give you access to Beta releases of Manager. We are constantly improving manager as well. So it works in different setups. It is not related to connectors.

You can already access pre-release versions of our connectors by going to the versions tab on the connectors page in Manager.


which you can shortcut to from:



yes, I use these already.
But I thought I can see them only because I have Betas activated.

But now I have tripple Beta status :slight_smile:


If you check your profile, you now officially have a Tripple Beta badge. Thanks, from all of us, for all the testing you’ve been doing!



so now the one with the least knowledge has the biggest badge :grin:

1 Like

OK, not unexpected, but I can confirm that Blender Connector Installation …
and my IFC, on Blender Dev Server, works by Blender Receive,
also on Windows 11 for me …


Hmmh, but the latest Blender 2.12.0 Beta Connector is broken for my IFC Stream.
The Warning was a bit longer this time.

Went back to 2.11.3 and it works again …

1 Like

Is this ifc file in If yes can you share the stream url? If not, please upload the ifc file to latest and try receiving from there.

If it still doesn’t work, please share the ifc file with us.


Jedd has it already and I sent the link to you now via PM.

Will try to upload again later.
Is the 1st repair for my IFC already on XYZ now ?

1 Like

Hey zoomer,

Link you shared is on XYZ which confirms my suspicions. We had an issue with IFC upload service which is fixed on “latest” now. it will make its way into XYZ in the next release. In the meantime try uploading same ifc file to “latest” and receive that on blender. Let me know if it works.

1 Like

I can reproduce an issue when receiving some of our internal IFC commits that have with int values larger than int32.

When setting the custom object properties on received blender objects, I was getting this exception

OverflowError: Python int too large to convert to C int

Unsure if this is an issue anyone else has come across. but should be a quick change to simply ignore attaching any property to the blender object that is out of range.