Blender Connector fail

My last experience is,

My IFC upload to XYZ did not stream down to Blender with 2.11.3.
Jedd fixed it on “latest” Server.
My IFC re-upload to “latest” did stream down to Blender with 2.11.3.

When 2.12.0 Beta came out, I tried downstream again and it did not work,
with a longer warning message.

Went back to 2.11.3 and it works again.

So I would expect it is about the Connector Beta ?

Does that mean my IFC is corrupt with too large numbers inside,
or that the uploader converts to too large numbers.

If you need, I can mail the IFC’s too you.
I exported as IFC 2x3, 4.0 and 4x1.

As BlenderBIM recommended using newest IFC versions, I just tried
4x1 version first. And as it worked for my own usage internally between
Bricscad, Vectorworks and BlenderBIM so far without problems,
I also used the 4x1 version here for Speckle testing.

Yep! ok this is a nice catch.
I can reproduce the issue on 2.12.0-beta

The problem is related to the attaching of custom properties of types that blender doesn’t support.
I’ve just implemented a fix which will skip the attaching of any property that fails to attach.

Just testing, your geometry receives fine.

My guess is that 2.11 is unaffected, simply because the problematic objects weren’t directly converted (in 2.12 we’ve made some improvements to how nested objects are converted).

I’ll push a 2.12.1-beta shortly, with this fix.

1 Like

Unlikely that I attach custom properties in BIM intentionally.
But yes, in Bricscad V23 there were some new Classification Options,
with a warning that these are not backward compatible, which I used.

As I had to go back to V22 for editing, maybe I even corrupted these
this way, but did not notice problems locally.

And thanks for the fix.

Do I still need to upload the IFC again (on the Beta Server) or was it all about
the Connector only ?

And generally, when upload options like IFC get updated on Servers over time,
this means that we also should re-upload our direct upload files from time to time ?

There’s nothing wrong with your IFC or Speckle Objects. Simply, there are a few property types that IFC & Speckle supports, that Blender doesn’t support attaching as custom properties.

Those properties are visible here, and accessible via python scripting.

It looks like blender only supports the following types: int, float, string, int[], float[]

With my fix, any property with unsupported types will now simply be ignored, instead of it causing the whole object to fail to be converted. :sweat_smile:
e.g. I see some polar coordinates (int[][]) fail to attach.

If you really need those properties, you can always inject a python receive script to re-attach those properties see Get window dimensions in Blender - #5 by gokermu

But most users just care about getting their geometry into Blender, the properties are a :cherries: on top.

This would be a fix just to the Blender connector

Thanks !
Found your Connector Update and installed. It is loading fine now.

And I see I have Objects with names.
I just miss the hierarchies.
E.g. there are 3-4 “Empties”, from my BIM Stories, but the Objects
are not parented under these like it is for the most top parent : Site.
Same for some Objects in Blocks/Symbols, their Empties are not above
but at the same level as the child Objects.

I get these hierarchies in BlenderBIM, which allows faster Visibility switching
by Story. Would that be tedious to implement in Speckle ?



1 Like