Blender Can't send image material

Hi team !
I have a problem like this, I tried create a new object element in blender and map material with color picture image bellow, so it just commit only geometry object.

This is a object in blender

are your team have any solution for that ?

Thank you !

Images, textures and bumpmaps are definitely not yet supported by Speckle.

If you are referring to the base colour pre-image application not matching the result then this is something we can review. Though I believe not all blender material types are fully supported - which were you feeding the colour values into?


It’s certainly possible. We did this POC. There are currently no ways to synchronize Revit Materials across models. Speckle Revit Material Sync POC - YouTube There are tons of these “Revit to Revit” workflows.

1 Like

But I think also should improvement for this, I saw some problem same with BIM360 before when we say to material use an image relative.

Nice job ! Any chance for blender ?

What @Greg_Schleusner demonstrates is that the material reference link to Raster resources on disk is saved and will persist so long as the same resource exists at the same path on the receiving machine. Revit<>Revit.

You’ll have to see if performance in Blender (or Rhino or Sketchup etc.) is equivalent.

It doesn’t transmit that image resource in the stream yet, and won’t be available, therefore, to the viewer.

I suspect more fragility cross-application but the POC demo might work that way too.

@jonathon I need to check , but I think we store the image as a blob in the stream as a raw object. That is sort of the main part of the workflow. These images tend to be saved in random places and so using “on disk” resources is never all that great across users

Ahh, in which case, I apologise - I was watching on mobile.

The blob storage infrastructure layer that has been added to Speckle Server is definitely there to enable this moving forward. So there is a more scalable solution for these assets than encoding into the stream data.

I’ll recheck the POC. thanks