Blender 4+ support

Hey guys,

I just installed Speckle Manager and the latest version of the Blender Connector (2.17.0).

Unfortunately, I cannot install it in Blender 4.0.1 which is the version of Blender I use.

Are there any plans for a release that supports the latest Blender version?

Hey @BIMvoice ,

We should already support any Blender version, including Blender 4+. Is Speckle the first plugin you are installing for that version?

If this is a fresh install of Blender 4.0, then Blender won’t have created AppData structure needed to install plugins, until you perform some action like saving a blender file, a preference, or installing a plugin via ZIP.

Unfortunate, but our installers need this AppData structure in order to tell what versions of Blender to install to.

Please follow these steps.

  1. Opening Blender and save a file (doesn’t matter what file), this should trigger Blender to create the AppData structure.
  2. From Speckle Manager, (re)install the Blender connector.


This is not a fresh install of Blender. I use other add-ons already daily.

I tried to install it using both approaches: from the Manager and as any other addon in Blender using the source file.

Still nothing.

  • Just to confirm, did you enable the Speckle connector from the Addons dialog within Blender?
  • Do you have BlenderBIM installed? We have some reports of Speckle connector not working well when BlenderBIM is installed.
  • Do you have a folder for speckle connector in the following path: %appdata%\Blender Foundation\Blender\BLENDER_VERSION_NUMBER\scripts\addons
1 Like

Hi, all!

I also have problem installing the latest version of Speckle (2.17) on the latest official build of Blender (4.0.2) via the Speckle Manager.
Every time I try to enable the plugin in Blender Preferences I got this errors …

I don’t have Speckle Folder in this folder - AppData\Roaming\Blender Foundation\Blender\4.0\scripts\addons

Well if I cannot use Speckle with BlenderBIM that would be a real issue.

Not possible to troubleshoot that?

I also had issues with Blender BIM and Speckle but currently they run
fine beside each other.

I usually have Blender latest stable and one of the newest Alphas or Betas
With constant updates of Alphas and migrating Blender Settings from
previous versions, it seems I brought some chaos in there.

Trouble started at a point where I could no more activate Speckle AddOn
after one of its updates …

I had to realize that that way my Blender 4 builds ended up with quite old
versions of BlenderBIM. And at one point Speckle Manager was no more
able to update Connectors or install them in all Blender’s Setting Folders.

The solution for me was,

  • cleaning up all Blender installations from BlenderBIM AddOns
    (by the recommended tedious uninstall procedure with Blender restarting)
  • cleaning up all Blender installations from Speckle AddOns
  • AFAIR I also needed to delete the hidden
    Users/XXX/.config/Speckle Folder or some of its content like …/connector_installations …
  • then first install Speckle AddOns via Manager
  • open all Blenders and check if Speckle is working
  • restart all Blenders, download and install the latest official BlenderBIM AddOn

For me Speckle AddOn installed fine that way and it worked again.
And Speckle was still fine after installing BlenderBIM again.

@Voronium from the logs you’ve posted, it looks like there may be a conflict with a different plugin MeasureIt_ARCH-development. Please can you try a few different versions of their plugin, hopefully we can find you a version that doesn’t conflict with ours. I’ll do a little experiments my end also.

I’ve been successful in using version version 230506 of blender BIM plugin with the latest Speckle Blender connector. It’s a couple versions older than the latest version. Hopefully this works for you, I’ll keep this topic updated when we have a timeline for supporting the newer versions of BlenderBIM.


@BIMvoice Its worth me adding that this isn’t exactly a problem with our plugin,
Conflicting dependencies is a notorious issue with Blender plugins. BlenderBIM have a big disclaimer about potential incompatibles.

We’re still looking into options from our end. But we can’t be compatible with every version of every blender plugin out there.

Just adding, this worked for me.

Completely fresh install of Blender 4.0 and install of the connector (2.18.1). Was not showing up in Blender at all, additionally under add-ons, (Edit>Preferences>Add-ons) — “scene” was not even a category.

  1. Saved a blender file to desktop (nothing in it, just dumb, didn’t even rename)
  2. Closed Blender
  3. Opened connector and uninstalled.
  4. Reinstalled immediately
  5. Opened Blender, and its there now.

Just confirming this did solve my issue.

1 Like

Thanks for sharing it @Kyle ! I’d be happy to see how you are utilizing our Blender connector.