Auto Receive function not working anymore?

Hello,

I am Taha, a computational designer at XtreeE, doing large-scale 3D printing.
We use Speckle Grasshopper connector in our workflow (for which we thank you a lot for the amazing work !), and the Auto-receive function of Receive / Send components are a key point of our process.

It’s been about a week that the auto-receive function seems to not work anymore.
The commit is in fact pushed on the web platform, but the component does not detect it to receive it automatically.
The only way to make it work seems to be to recompute the grasshopper file at each operation, or use the “Receive” button manual way.

I tried reloading my script multiple times, installing previous versions of Speckle connector (back to 2.16, where I am sure it was working), and tried it on 3 different laptops, but no results.

Do anyone have this issue too or is just me ?

Thank you for your help
Best
Taha

Thanks, @Taha_Bouizargan, for bringing this to our attention. We can investigate, but from our perspective, nothing has changed.

We will report back here.

Hey @Taha_Bouizargan ,

I have just tried, and it seems to work when I recompute the solution. Can you provide more details on your expected behavior? Sharing the Speckle Model URL and screen recordings would help us assist you.

Hi Bilal and Jonathan,
Thank you for investigating the issue.
@gokermu The auto-receive function used to retrieve the result without the need to recompute the solution, but directly when a new version of Speckle Model has been pushed. For me, that was the purpose of “Auto” receiving, as the user do not know when his collaborators pushed a new version of the model they are working on ?
Here is simple model and a screenshot of the expected behavior:


https://app.speckle.systems/projects/a1f10a42f4/models/2284fd38b1%4038c6407ca2

Thanks again !
Taha

1 Like

I’ve just checked and it seems that this issue is related to the server change. When you try to receive from xyz, it works fine. Since this is a regression in the feature, I will add a ticket to our backlog. Thank you for bringing this to our attention.

2 Likes

Hi there,

Any updates on this subject ?
Still not working on my side

Hey @Taha_Bouizargan, we have it registered as a task item. It didn’t make it into the 2.19 release, so we’ll review whether it is for the next release or a hotfix for the current one.

We’ll let you know when it ends up being resolved.

1 Like