3D Viewer Visual doesn't color by parameter

Hi mr @gokermu.
I just tryed it and it is verry Cool, but i dont knew if we can change the color by any data ?

2 Likes

@Mohamed_Manseur ,

You definitely can. Select the visual first. Whichever parameter you want to color the model using, drag that parameter into the Object Data input.

I’ve used area parameter to color in the below image.

1 Like

@gokermu thnks for replying
This is what i did but i am not sure if the data parameter has to be a number or text, i tried the two parameters and i always have one color for everything…
I will try again

Can you share the commit you used? pbix file would be even better. If you don’t wanna share it publicly, you can send a PM.

1 Like

Thanks for sharing the file and commit. It’s really helpful. I have a suspicion and I’ll coordinate w the team to confirm. we’ll try to fix this asap.

1 Like

Thank you @gokermu , it will be very helpful :+1:

1 Like

Hi mr @gokermu i just want to check up if there is some news about the issue?

1 Like

Hi @Mohamed_Manseur ,

We were busy testing the new release last week. I created an issue for this. We’ll look into it and i’ll let you know when we fix it.

1 Like

@gokermu Thank you :slightly_smiling_face: :+1:

1 Like

Hey, I would like to follow the update on this topic as well !
I would like to color my different revit elements on the viewer based on parameters. But it just display one color haha :slight_smile:

And even if my parameter is a text, I have the choice between First, last, amount… :slight_smile:

image

Btw, amazing tool !!! Thank a lot everybody ! Great work !

1 Like

Hi @BaudouinNP and @Mohamed_Manseur!

I just noticed what could be the issue here. Could you rename the Object Data field you’re connecting to just be the name of the field with no prefix?

i.e. Instead of Premier Surface, just call it Surface and see if that does the trick?
image

We’ll look into a longer term solution meanwhile :wink:

EDIT: from comment below, renaming can be done on the visual directly using Rename for this Visual
Screenshot 2022-10-24 at 11.24.51

Hey,
Nope we can’t …
it always come with the prefix of the option we choose… Probably because it doesnt recognize the data format :slight_smile:

You mean you don’t have this option?

Screenshot 2022-10-24 at 11.24.51

Ahh sorry! Yes it worked !
Great trick haha
Thanks a lot

1 Like

Perfect! Anyway, we do have the issue on github still open to try and find a better approach to this

3 Likes

For me it didnt work, I dont knew why?

1 Like

Hi again i was just wondering if there is some news about the issue because for me changing the name did not fix the problem

1 Like

Hey @Mohamed_Manseur ,

No updates yet. Still trying to figure out why it doesn’t work.

1 Like

Ok, thanks for replying. there is another issue the data take a lot of time to charge on power BI i don’t know if this has any relation with the net speed or not?