🌏 3D Terrain and Buildings: Create 3D Context Maps with QGIS and Speckle

:rocket: QGIS Connector joined the 2.14 release party with mind-blowing features: 3D buildings, terrain models, and texture meshes! :city_sunset::mountain::office: Grab source material from open data providers or your own GIS libraries. Even if you’re not into GIS, you’ll love this!

@Kateryna created this awesome tutorial on creating 3D context maps using QGIS and Speckle. :books::world_map:

I can’t keep from talking about this with everyone, and you may have seen @pauldotnet has already been putting these through their paces. So don’t miss out on gaining instant insights for your project modelling! Happy modelling! :sparkles::art::muscle::rainbow:


@Kateryna I’m trying to use Mapzen, and configured the same connection as you, getting some psychedelic stuff instead of the black and white gradient you showcased. any idea why?

1 Like

hmm not sure, try saving some region as tiff and set up a proper single-band symbology, let me know if it works!

Hi @Kateryna ,
Saving the region as tiff results in the same coloring, and I checked in the symbology tab, it’s in french but it says “coloured data with single band”

Maybe it could help if you share a screenshot with your parameters

With Mapzen tiles I have normal symbology allowing to change between Singleband gray etc. So I tried to replicate with OSM tiles.

Here are the properties of the Tiles layer, looks like your case:

When I save it as tiff, I am able to change the symbology to a proper list of options:

I don’t really know why is this happening, but I would expect that after saving, tiff layer should become a normal editable raster layer. If not, well… we would need to figure it out :sweat:

Ok… well yes now I see all the options when saving as TIFF, changing to “singleband gray” just makes the psychedelic stuff gray scale… no idea what’s happening, maybe some display/performance issue…

Ok, I was using QGIS 3.22, updated it to the latest version, and didn’t have such issue anymore :man_shrugging:

1 Like

Ok I am able to reproduce!

When adding a connection like Mapzen, the Interpretation should be set to Terrarium Terrain RGB, this feature is described in the documentation and is available from QGIS stable version 3.28 and up.

Probably, you just need to update QGIS:)

UPD: I can see, you did it 1 minute ago, awesome :partying_face: