Unable to Recieve Commit - Dynamo

I’m trying to import a number of curves from Grasshopper into Dynamo but seem to be falling at the first hurdle. this has worked for me before from the same stream into the same dynamo graph. I cannot work out whats wrong!

My Recieve node throws up the error:
" Method not found: ‘Void Speckle.Core.Logging.SpecleException…ctor(System.String, Boolean, Sentry.SentryLevel)’ "

Any help would be greatly appreciated!


Hi there @Remwan

Welcome to the community! Feel free to Introduce yourself 🙆 if you feel like it!

It seems like for some reason your install may be corrupted? That error comes from our logging service so we can know when things go wrong, but should definitely exist :sweat_smile:

Do you have any other connectors installed? Are they all in the same version? I’m thinking maybe the Revit plugin is conflicting with the Dynamo one… Do upgrade everything to the same version if this is the case.

Also, can you try uninstalling it an re-installing it again? Something may have gone wrong during an update :sweat_smile:

Lastly, could you let us know what version of Speckle Manager and connectors you have installed?

Thanks for reporting this :slight_smile:

1 Like

Hey Alan,

Thanks for the speedy response!

I’ve removed the Revit connector, wasnt really needed anyway. I’ve also reinstalled the Dynamo connector but im still having trouble.

Manager and Connector versions are as follows:

Manager: 2.1.11
AutoCAD: 2.2.4
Blender: 2.2.5
Dynamo: 2.2.4
Grasshopper: 2.2.6
Rhino: 2.2.4
Excel: ???

Not sure how to check the Excel version.

I would be happy to uninstall the AutoCAD connector if you think that will help.

Thanks Again

Interesting… well at least something changed! :sweat_smile:

Can you try installing the latest beta versions? For that, you can go to Speckle Manager settings page and activate the “Beta Versions of Speckle Manager”.

If that doesn’t do the trick, you can also try with the latest beta versions of connectors. If you need to roll back to the current version, just uninstall the beta, deactivate the option and reload the manager to show the stable version to install again.

Do make sure you update all connectors if you try this :slight_smile:

Soo, i tried the beta for both the Speckle Manager in beta on its own, then Tried the Dynamo in beta and im getting the same message as before :upside_down_face:. I havent installed any other connectors as the data is already on the stream.

Anything else you think i should try?

@Remwan did you ever build the Dynamo connector (or others) from source? It almost seems like there is an old version of some DLLs stuck somewhere…
A quick thing to check would be the list of packages available inside Dynamo > Packages > Manage packages:


Also, did you make sure to close any software potentially running Speckle when you uninstalled and reinstalled the connector?