Unable to install connectors from Speckle Manager

@teocomi Any idea why the ETABS connector isn’t present in Speckle Manager for me? It shows up on my other machine, but not this one. I’ve tried a fresh install of the manager and I have v2.1.10.

This looks like proxy issues from the manager that @teocomi and @cristi are frenetically investigating as of yesterday :disappointed_relieved: (basically corporate networks and some proxies make our lives quite difficult).

@Reynold_Chan could provide you with a pre-built installer of the latest version if you need it now!

Thanks @dimitrie. No need for a pre-built installer on my end, I just wanted to make sure this issue was raised and on the radar!


1 Like

Thanks for the heads up @dtnaughton !
You’d help us even further if you could:

Cheers :pray:!

1 Like

Hi there.

I’m using speckle manager 2.1.10.
I’m trying to install the plugins that we would be using. e.g revitimage

opening devtools, logs shows everything sucessful but execution failed:


Unknown is not very helpful. How do I proceed?

Hey @eugeneida thanks for the report. I’ve merged your thread with a similar one.
Could you please try the above? Although you are haveing slightly different issues it might work, thanks!

Hi, alright.
Looked different so I started a new thread.

Anyway, it still doesn’t work, it is the same except it doesn’t say Write to file successful now

SUUID : 9f27eb2d-bea5-43a4-b568-551bd809d8b7

So, in this case I think it might be because of some local IT policies on you machine that prevent the execution the actual “connector installer”.
Would you be able to put us in touch with someone from IT so we can work out a solution together?

Here’s a direct link to the revit connector, so you can at least start using it! But keep in mind it will not auto update unless installed via Manager.

I enabled the beta version in settings and get the following:

I have an active internet connection but it is through a work VPN.

Is it ok to share my SUUID publicly or should I DM you @teocomi ?

You can send the SUUID via PM!

It seems your VPN might be cutting manager off completely from the WWW, can you disable it temporarily and retry?

Disabled the VPN and the connection issue persists (after a reboot too). PMing now.

Hey Dan, I’m afraid the only solution for you is to ask IT to allow some of our core domains, please see this list.
We’re also happy to jup on a call with them if it helps!

I’ll touch base with our digital lead and see the best way we can set this up. I’ll let you know!

1 Like

@teocomi Hey Matteo, any chance you’re available now for a quick chat? I’m on a call with IT lead.

For others having similar issues - manager not connecting to the interet - a fix is available in the latest release:

:point_right: Speckle Manager 2.1.11

1 Like