Unable to build Speckle-Server due to Dependency Issues

Objective: Run the local Development Server following the tutorial on the website.

Issue: Several errors, the crutial one probably being the cyclic dependency graph.

Error Code:

Leading to:
YN0000: The command failed for workspaces that are depended upon by other workspaces; can’t satisfy the dependency graph.

Example (Ubuntu):

System Info: I have tried several different versions of Node (18.18, 18.16, 20) and also tried Windows 10 / Ubuntu 20.04.

1 Like


Windows is definitely not going to work, but it should work on Ubuntu :thinking:
Can you provide the following?

OS & OS version
Node version
Speckle Server version/github commit
Have you made any customizations to the source code?

Also - what command are you trying to run? It’s not clear from the screenshots if its dev or build

Hej, the errors occur during the execution of “yarn build”.

My supervisor is running the server perfectly fine on windows, so i am confused you say it will never work.

I always cloned the most recent version on several different days from github and did not make any changes but always got the same errors the last week.

OS and Node as specified in the post (20.04 Ubuntu and i tried several Node versions from 18.16 to 18.18, 20)

Hi @FliXii

Thanks for trying again and for following up with more detail.

I created a new virtual machine with Ubuntu 22.04, and installed the dependencies as follows:

  1. I used DigitalOcean, but other virtual machine environments & hosting should yield the same results:
    1. How to Create a Droplet :: DigitalOcean Documentation
    2. Connected to the created virtual machine with SSH: How to Connect to Droplets with SSH :: DigitalOcean Documentation
  2. Once connected to the machine I ran apt-get update && apt-get upgrade
  3. curl -o- https://raw.githubusercontent.com/nvm-sh/nvm/v0.39.5/install.sh | bash
  4. nvm install 18
  5. nvm use 18
  6. Install Docker Install Docker Engine on Ubuntu | Docker Docs
  7. I then followed the instructions at Local development environment | Speckle Docs

I was unfortunately unable to replicate your reported issue. I was able to run speckle server using the above instructions and run our full test suite without any issue.

Would you be able to please provide the output of all of the following?:

  • node -v
  • lsb_release -d
  • yarn --version
  • corepack --version
  • docker version
  • git version

Thank you


Hello Iain,

I have now used Github Codespaces to run a VM.
Everything seems to work there. The codespace opens the 3000 port (https://myVMname-4wp5xgvxrvp2qpqg-3000.app.github.dev/) and I see the speckle login page.

However, the page keeps refreshing in intervalls of about 1 seconds forever.

And on Port 8081 i get a loginpage aswell but it fails to fetch after the request.

Any Ideas on how to fix this? I cant find any codespace related problems regarding this issue.
I will try to set up a Digital Ocean VM and also try there meanwhile.

  • node -v = v18.16.0
  • lsb_release -d = Ubuntu 20.04.6 LTS
  • yarn --version = 3.2.0
  • corepack --version = 0.17.0
  • docker version = 24.0.7-1
  • git version = 2.42.1

Hi @FliXii

If you open the developer tools console it will indicate that the frontend is unable to connection to localhost (

To resolve this you will have to edit the file docker-compose-speckle.yml to replace with your GitHub Codespace URL e.g. https://your-codespace-url-80.app.github.dev.

There are three locations where this needs to be replaced. In speckle-frontend-2, the NUXT_PUBLIC_API_ORIGIN property, in speckle-server the CANONICAL_URL property and the FRONTEND_ORIGIN property.

Once I changed these values, I was able to log in. However, the file-import feature wasn’t working as it returned a 401 error which requires some further investigation.