The blender connectors is not showing on the preference addon on blender 3.6.5

The blender connectors is not showing on the preference addon on blender 3.6.5 and i already downloaded the connector on speckle connector.

1 Like

Sorry to hear you’re having issues.
Please can you let me know if this is a fresh install of Blender 3.6?

We’ve noticed an issue with our connector installers not installing to fresh versions of Blender that have not generated their AppData structure yet.

If this is the case, you could try saving a blender file (this will trigger Blender’s AppData structure to generate) then reinstalling the Blender connector through Speckle Manager.

If this fails, then we also offer a manual ZIP installation method on
You can see our docs for manual install instructions.

Please let me know how you get on,
I’d be happy to assist further if neither solutions don’t work for you.

I think it may be already enough to just start Blender (?)
But very likely I also did Setting changes (Which save in that file structure)
or at least by migrating Settings from the previous Blender version.

But if I got that right, the latest alpha 2.17 (?) did not work for me too.
AFAIR I reverted to latest stable connector 16 (?)


I gave 2.17 alpha another try on my 3.6 and 4.1 Blenders.

When trying to activate the connector I got the error message.
So I tried to went back to 2.16 stable again.

But now I can’t activate any connector successfully on any Blender version.
Traceback (most recent call last):
File “/Applications/”, line 333, in enable
mod = import(module_name)
File “/Users/name/Library/Application Support/Blender/3.6/scripts/addons/bpy_speckle/”, line 10, in
from bpy_speckle.operators import *
File “/Users/name/Library/Application Support/Blender/3.6/scripts/addons/bpy_speckle/operators/”, line 1, in
from .users import LoadUsers, LoadUserStreams, ResetUsers
File “/Users/name/Library/Application Support/Blender/3.6/scripts/addons/bpy_speckle/operators/”, line 7, in
from bpy_speckle.functions import _report
File “/Users/name/Library/Application Support/Blender/3.6/scripts/addons/bpy_speckle/”, line 5, in
from specklepy.objects.graph_traversal.traversal import GraphTraversal, TraversalRule
ModuleNotFoundError: No module named ‘specklepy.objects.graph_traversal’

Also I noticed that smoething is wrong with the Installer from Speckle Manager.

I have Setting Paths for Blender 3.6, 4.0 and 4.1.
(Blender 4.0 is no more installed)

But when trying to install from manager, I see that it does not copy Speckle Addon
in the 4.1 Path. And I realized that the previous Addon in 4.1 was only 2.15.
Which likely only came in by migrating 4.0 Settings for 4.1.


Something is really strange.

I am really not able to activate any Speckle Connectors in Blender 3.6 or 4.1 Alpha
which I installed by Manager (2.15, 2.16, 2.17 Alpha3).
AFAIK I saw that the Manager does install the Addon in Blender3.6 but neither
in my 4.0 nor 4.1 Settings Folder.
I can’t activate the Addon though, just an error message.
If I manually copy the Addon Folder over to 4.0 and 4.1, I get an even 5 times
longer error message for Blender 4.x.

So I tried the manual Apple ARM 2.17 alpha installation ZIP file and installed
from Blender 4.1 Preferences as told.
No “Scenes” Addons to find.
So I checked my Blender Settings Folder - total havoc.
Speckle forgot the parent SpecklePY Folder and flooded my Addon Folder
with all Speckle Files at top level !

If I open the ZIP I see that there is no folder hierarchy at all in it.
This is not a typical Addon installer Zip.
I assume it is the installer data for the manager.

Let’s hope time machine will work and recreate my Blender Settings.
(EDIT : Time Machine could fix it)

Something is not working as expected here.
I am on a M1 Mac Mini, Sonoma 14.2 (23C5030f) Public Beta.

You shouldn’t expect Manager to install for any 4.X versions yet.
We’ll add support once they are out of beta and have done some internal testing/validation for us to be comfortable calling our connector “Stable”.

Although, you can use the manual zip to install the plugin.

Your issue for 3.X versions sounds more concerning. I think this may be an issue with our installer for mac not cleaning up old versions before installing new ones.
I’ll investigate and try and see if I can reproduce.

In the meantime, If you’re looking for a fix, please can you follow the following steps:
I recommend doing this for all Blender 3.X versions

  • Uninstall the Blender connector through Manager
  • Delete Library/Application Support/Blender/3.X/scripts/addons/bpy_speckle
  • Delete ~/.config/Speckle/connector_installations/Blender 3.X
  • Finally, reinstall the Blender connector through Manager or the manual zip at

Please let me know if this resolves your issue.

It did delete bpy-speckle folders from active Blender 3.6 Settings Folder, orphaned 4.0 Folder
but forgot/ignored active 4.1 Folder …

Did manually for 4.1 Folder too.

Wasn’t aware of this Speckle Settings Folder …
Deleted Blender Installations for all Versions.
(There was still a 3.5 version which does no more exist - and interestingly
a 4.1 version, so the installer at least found it …)

I have chosen 2.17 Alpha.
Manager installed into Blender 3.6 Settings Folder only,
neither to 4.0 nor 4.1.

Unfortunately not really or as I would have expected.

I started Blender 3.6

  • no Speckle panel visible
  • went to Settings/AddOns
  • activated Speckle (2.17 alpha)
    → Activation aborts, same Warning as always

I just wanna pitch in and say I have the same problem and can’t seem to get the Speckle addon for Blender to work in any way.

Please can you let me know if you’re using Windows or Mac