Structural2DLoadPanel GH to GSA - Issues with LoadCaseRef

I’m having some difficulties defining 2D load panels in GH and sending them to GSA. I’m not sure if this is user error, a bug or a combination of the two. Observations as follows:

  • Speckle GSA returns “load case references not found” and assigns the grid area load to load case n+1. I have tried a couple of different inputs to the “LoadCaseRef” node in GH (“1”, “L1”, “1: testcase”), none of which resolve this. I’m assume the input to this node should just be an integer?
  • The grid plane referenced by the grid load case is placed at the negative of the correct value in GSA (i.e. correction elevation is 10m, grid plane has been passed to GSA at -10m).
  • Multiple additional gravity load cases seem to be created each time the receiver is run. Doesn’t seem to be any pattern to how many are added each time - have run the receiver ~15 times and >1000 additional gravity load cases have been created.

Speckle GSA
Speckle 1.8.24 (reverted back to due to missing components in 1.8.31)


Hi Andrew, thanks for reporting this!
SpeckleGSA is a community contribution, so I’ll ping @daviddekoning who hopefully will be able to assist :grin:

Thanks @dimitrie!

@AndrewBlackie could you share your GH definition (or even a screenshot of the relevant part)?

1 Like

I am blind or have not had enough coffee - thanks @teocomi!


Hi David, see below:

On the duplicate gravity load cases - these seem to be doubling each time. (1,2,4,8,16…)

Hi Andrew,

Have you defined your LoadCaseRef i.e. StructuralLoadCase “2” first?

@George The load case has been defined directly in GSA, rather than in GH.

Is load case actually called “2” in GSA then? For me it works with the text name, rather than the number as input of “LoadCaseRef”:


I’ve tried the following formats:

I mean just adopt “testcase” as the input like image above

Tried that - no luck

@AndrewBlackie - this is a bug. It has been fixed and will be working in the next release.

1 Like