Speckle Power BI Viewer Stuck on loading


During the past few days I have been working on a Bill of Quantities report that incorporates data from Revit.
The 3D Viewer sometimes works, other times does not, and gets stuck on the blue bar loading, and after some time an “i” symbol pops up at the bottom with the following message:

Incomplete Data Input

“Stream URL”, “Commit Object ID” and “Object ID” data inputs are mandatory. If your
data connector does not output all these columns, please update it.

However when I check the data query, it is populated as expected.

I have tried changing URLs, have used both stream and project URLs, and updated permissions (what worked before was Public Stream, Privacy Level None).
I am using Revit 2023, Revit Connector 2.17, Power BI Desktop, powerbiSpeckleVisual.2.17.0
I’d appreciate your help.


Hi Specklers ,
I think I have the same problem. I can’t display my model, Can you help us please Mr @gokermu?

1 Like

Hey @RevitCivil @Anastasia ,

Welcome to Speckle Community!

Sorry to hear you are having problems visualizing your models. Can you make sure your project is set as Link Shareable/Public?

1 Like

Yes, it is set as shareable.

Thank you very much @gokermu, I hope you find a solution quickly @Anastasia, normally it works well.

I think the loading stuck problem occurs when restarting a pbix file, maybe there is a better way to save before closing PowerBi

1 Like

Hmm, can you please share the Speckle Model URL so I can try to reproduce it?

Hi @gokermu, here is the link Viewer - RV5 - Speckle
I noticed that when I open a guest browser, and paste the link, the visual will not load (just the progress bar keeps loading), although public access has been given.

Speckle similarly this link gets suck at about halfway through.

However query data in power bi is populated correctly, so it is not a credentials issue.
thank you in advance!

Hi @Anastasia ,

I was able to receive and visualize the link you shared using 3D Visual in Power BI. Here’s how it looks on my end:

Can you try clearing permissions and receive again?

Thank you for your time!

Unfortunately I can’t make it work.
Did you use the stream/commit version of the link or the project/model, I’m not sure if it makes any difference.
What I noticed is that with the original link I was using, which is this one, Viewer - VIP5 - ISOLATE - Speckle
I can have the visual working for some of the earlier versions, but later versions never load.

Just to make sure:
When I reupload a model and a new version is created, I can either use the link that refers to a specific version

or the general one for the model which will show the latest changes (I suppose)

In Power BI, I use “Speckle - Get stream by URL (Beta) (Custom)”
Then I select Public Stream, and for “Select which level to apply these settings to” setting I choose the bottom row (same as my link)

Is that workflow correct?

1 Like

Hey Anastasis,

You can set it to the top level (app.speckle.systems) so next time when you receive from this server again, you won’t have to authenticate. If you set it same as your model URL, then you will have to authenticate if you were to receive a different model from the same model.

Can you try changing the permission to Server URL from Data Source Settings and see if it solves?

Power BI connector supports both URL types so it shouldn’t make any difference. I used this URL: Viewer - RV5 - Speckle

Can you share a screen recording of this behaviour? Here’s a tutorial that shows the expected behaviour: https://youtu.be/euoyfFmgn-s?si=gWSJGSgDoqT9Obas&t=276

Hello again!

I tried privacy settings as you mentioned.

I’m sending two videos, using the first and last versions of this project, and bringing them in power BI. Viewer - VIP5 - ISOLATE - Speckle

using the first one Viewer - VIP5 - ISOLATE - Speckle
it works as expected

When I add a the last version, it gets stuck in loading, as shown in this video

the same thing happens when I create a new empty file and load only the latest version, or if I try to connect the other model that I sent you originally.

However, I selected fewer elements to push into speckle in a new “lighter” model, and it loaded just fine.
So it feels as if there is something to do with the contents of the model.
Although it’s weird that you were able to visualize the link!

Thanks for sharing the video recording @Anastasia. This is happening because you are actually copying the version URL.

If you remove “@” + VERSION_ID, you will be able to view the latest version uploaded to the model.

I understand that, however the only reason I tried it is because the link without the @XXXXXXXXX won’t load either! I had the same non-loading issue with the model link Viewer - VIP5 - ISOLATE - Speckle

I do not know what to say @Anastasia. It takes about 10 seconds to load on my end.

Can you create a screenrecording showing what happens when you try to receive this URL: https://app.speckle.systems/projects/011fc423c2/models/cff9d804ff

here’s the screen recording, no luck :confused: it’s been about 5 minutes and still no image…

1 Like

Can you test with the following visual please?

powerbiSpeckleVisualAA98F06515D847E8ACB33BAB487244E0.2.17.0-rc (1).pbiviz (1.7 MB)

Mystery solved, it was a company firewall setting related to SSL certificate pinning. I am now able to load the models at last!

1 Like

@Anastasia Great to hear you solved your issue! Thanks for sharing the solution too. Feel free to share your dashboard once you are done with it :grinning:

1 Like

Thank you for your time and patience! If anyone has a similar issue, try connecting through another network and see if the system persists, and if a company firewall policy is applied, check with your IT Department.
I’ll share my dashboard soon!

1 Like