Speckle not showing in Blender

Hello Everyone!
I am new to the speckle world. I was trying to install speckle in blender, I did it via the manager, and couldn t find a way to have it installed. It doesnt show in the add ons
I tried to delete all the versions of blender, and to rll back to version 3.2 but still no speckle in Blender
If anyone could help me would be great !

thanks !!

Hi @Julien_comman ,

Welcome to the community! Feel free to Introduce yourself :person_gesturing_ok: to the community if you want to! :smiley:

What version of Blender are you using? I think we are only supporting up to 3.2 atm.

Regular Setup

When you install the Blender connector, it should appeaar under Edit > Preferences > Add-ons when you search for Speckle. Make sure:

  • Enabled Add-ons Only” option is unchecked
  • Category dropdown is set to “All

If setup doesn’t work

If setup from the manager didn’t work for you or you want to install the Blender connector on an unsupported Blender version (e.g. 3.3.):

  1. Go to %appdata%/Blender Foundation/Blender/version-number (2.9, 3.1)/scripts/addons.
  2. Copy bpy_speckle and modules folders from here.
  3. Go back to %appdata%/Blender Foundation/Blender.
  4. Select the folder with the version name you want to install Speckle to.
  5. Go to scripts/addons. Create them if they don’t exist.
  6. Paste copied bpy_speckle and modules folder here.

or🤔…

  1. Download this zip file from :point_right:here:point_left:. It contains bpy_speckle and modules folders for Blender connector 2.7.
  2. Go to Add-ons under Preferences and click on Install.
  3. Select the zip file.
  4. Click on Install Add-on.

After you’re done with these steps you should be able to see Speckle under Add-ons. Enable it from there. If you face any issues during the initial run, restarting Blender will fix it.

Let me know if this works for you.

hey,

first of all, huge thanks for the reply!
I am using mainly 3.3, but while installing speckle I noticed it s up to 3.2 only - so I switched back to 3.2, but still couldnt managed to install.
And now even with the two solutions you proposed I couldnt manage to make it function either :frowning:


I got this error message
To note : My blender is through Steam - I guess it can have an impact

Have you tried restarting Blender? Giving an error right after you install is normal.

1 Like

You re a hero
it did the trick !
a huge thanks for the time you took to help, it s greatly appreciated

4 Likes

Great🎉. Fee free to ping us if you face any other issues

2 Likes