Speckle Manager - accounts get removed and no connectors available

I’m having problems with Speckle Manager:

  1. my account keeps getting removed from Manager. Once I authenticate after couple of minutes it’s no longer there (“No accounts” banner is shown again)

  2. I cannot see any connectors listed available to be installed from the Manager

I’m logging into Speckle beta server v2. I don’t think its firewall related issue (I am able to authenticate), I also don’t think it’s Manager’s app server communication issue (I received notification and successfully updated Manager to new version today).
Maybe it’s Windows user privileges related issue? Do I need to be an admin at any point? I was able to install Manager as non-admin, Manager seems to open and work correctly but maybe just up to a point?

Hi Pawel!

Sorry to hear about this, it must be quite annoying!

A corporate firewall/vpn could still be blocking some addresses needed by Manager even if you can log in to the beta server and even if it updated successfully…

Could you please:

  1. open the settings page
  2. open the dev tools
  3. click refresh
  4. report any error messages you might see there

Regarding the accounts, can you please check if in %appdata%\Speckle there is a file named Accounts.db?
If you have a sqllite viewer installed, could you also check it contains any data?

Manager and the connectors do not require any admin privileges, so this seems more of a firewall/antivirus issue! If you have another non-corporate pc to try with it would also help us remove some variables form the equation:)

Anyways, have a good weekend!

Hi Mateo,
I don’t have %appdata%\Speckle present, there’s only %appdata%\speckle-manager folder present and it doesn’t contain any Accounts.db as I browsed through the subfolders.

as for DevTools, here’s the output I get (see that my account is shown, but vanishes after couple of minutes):

Does your antivirus have a quarantine/vault that you could open and see if these files have been moved there and marked as malicious?

Hi
I managed to install Manager with no problem on private PC and connectors are shown and install so sounds like this could be firewall indeed. I’ll try to investigate with IT department

:raised_hands: Seems like we’re getting closer to the issue, thanks for checking!
Here are some of the domains Manager needs access to and that the IT department should whitelist: FAQs | Speckle Docs

hey, i got similar issue while getting the speckle 2.0 connectors, i did what you said about looking dev tools and i get this:


And in console I get this:

Do anyone knows why is this happening and how can i get the revit speckle 2.0 connector?

thnks in advance!

Hey @lourdes ,

Sorry about that and thanks for the screenshots! It also seems like a vpn/firewall issue, as Manager can’t reach the website hosting the connectors.
We’re looking into an internal fix, in the meantime, you could ask your IT department to whitelist these URLs: FAQs | Speckle Docs

1 Like

@lourdes @simplynail if you get a chance, could you please try install this beta version of manager and see if it’s any better?

I’ve changed the address it uses to retrieve the list of connectors, and hopefully that’s not blocked.

Thanks!

1 Like

I ran into this issue today, and I got the connector tile to show up again by uninstalling manager, then deleting the %APPDATA%/speckle-manager folder. then I re-installed and it the connector tile was back

1 Like

Hi,
After installing the new beta now I have no problem getting connectors installed.
Accounts also seem to be kept so looks like it’s solved (for me)

Thanks for picking this up!

2 Likes

Hi @teocomi!

Hope you are well! The beta version that you shared didn’t work for me!

I’m not seeing any connectors either, any clues? Should I check VPN/Firewall issues with IT?

Thanks!

1 Like