Speckle crashing Revit 2020 and 2022

Hi all,

following the latest update, my Speckle Connector is crashing Revit 2020 and 2022 as soon as I open a file - including a brand new one.

I’ve tried uninstalling and re-installing an older version, but the crash still occurs.

Is this happening for anyone else?
Any suggestion on how to identify the actual isssue causing this?

Thank you in advance.
thank you
Regards

Oh no, sorry to hear that!
It seems related to this: Revit won't fire up Speckle - #8 by Fubar

Are you getting any error messages? What older versions have you tried?

Thanks for the hint - no sure it’s the same issue though.

I’ve done some more testing and tried the following:

  1. Clean install of Speckle Manager and Speckle Revit Connector

  2. installed Speckle v2.6.4 - which works fine, but Revit crashes when quitting

  3. updated to v2.6.5 - works fine, but Revit crashes when quitting with the following Error Report:

  4. updated to v2.7.0 - same as above

  5. updated to .v.2.7.1 - same as above

when updating to 2.7.2 and 2.7.5 Revit crashes as soon as a document is created or opened
with the following errors:
Speckle_CrashError_1
Speckle_CrashError_2
Speckle_CrashError_3

so the issue only happens with 2.7.2 and 2.7.5.

Hey @giopez ,

Thanks a lot for the tests, it helps a lot as we cannot reproduce it.
We’ll look at what changed between these releases!

Any other specific Addins that you are using?

As an additional test, you could try moving the other addins outside their usual folders (and them move them back).
So to see if it might a conflict with one of them.

Otherwise, we might send you a beta version to try out.

Addins are usually stored in either:

User Addins:
%appdata%\Autodesk\Revit\Addins\
%appdata%\Autodesk\ApplicationPlugins\

Machine Addins (for all users of the machine):
C:\ProgramData\Autodesk\Revit\Addins\

Addins packaged for the Autodesk Exchange store:
C:\ProgramData\Autodesk\ApplicationPlugins\

Autodesk servers and services:
C:\Program Files\Autodesk\Revit 2016\AddIns\

Let us know how it goes!

I have exactly the same problem. Revit '22 crashes every time I close. The problem goes away when I disable Speckle. So now I will enable Speckle again and enable one addin at a time until the problem starts again. Exciting work which might take a while …

1 Like

We’re aware of this issue, unfortunately it’s caused by a third party library and we are waiting for them to release a fix - hopefully soon!

Will also investigate again and see if we can find a workaround…

Sorry for the hassle!

Thank you Matteo.

I have a number of 3rd party add ons and I haven’t yet had time to investigate if something is clashing there too - so I’m sticking to Speckle v.2.7.1 for now.

I think we could follow this issue in Revit connector 2.6 crashed Revit '22 · Issue #1352 · specklesystems/speckle-sharp · GitHub