Speckle 2.5 installation issue GH connector

Hey all,

Last Friday I saw the notifications regarding the Speckle 2.5 updates, so I wanted to try this out today! However, I couldn’t get the GH connector working after the update to 2.5.0 and 2.5.1. It didn’t appear in the Grasshopper ribbon. I tried reinstalling the connectors for Rhino and Grasshopper several times, including trying to run the Speckle Manager as administator and rebooting in between. However this didn’t work :frowning:. The Rhino connector worked fine btw!. So I tried installing the GH connector v2.4.2 version again and this worked for me.

Now I had a look in the Grasshopper Libraries folder where the SpeckleGrasshopper2 folder is located. It seemed that the GH assembly .gha file was missing when installing 2.5.1. When installing 2.4.2 it appeared there again.

Have you experienced similar issues? Or do you perhaps have an idea what causes this problem?



Hey @GerranLankhorst!

Thanks for reaching out, we got a report from another user this morning so we’ve already pushed version 2.5.2 of grasshopper to fix this. You should see it appear any moment in your Manager!

1 Like

Thanks for the quick action and reply! It’s now working again :ok_hand: