Special characters in rows may cause color mismatch

Dear Speckle Family,

I hate to throw a curveball but I am experiencing a coloring issue. To be concise:

  • Yes, I am using the latest connectors and visuals
  • Yes, I have tried matching the sorting ascending values and parameter values
  • Yes, I have tried cutting and pasting the visual to refresh

After many attempts to find what may be wrong, the only thing I can see is possibly connected to what @JdB mentioned earlier about special characters not working but that was in the parameter name. In addition to the Name parameter for rooms, I have the Level, and Zone. All 3 parameters are structured the same data wise, meaning they are all Text unit types, Not summarized, uncategorized. The only difference is my zone values (row values per room not parameter name) may occasionally contain a comma. For example, Room A may have a zone value of A,B. I haven’t tested it fully but given that every other parameter whether I use Name or Level to color works and matches except when I use Zone, the comma seems to be the culprit.

So with this said, is this the issue and are there any plans to fix and include special characters into allowing colors to match properly? In the meantime, what would be some workarounds? Would I have to do some power query or make a custom column that formats values with a special character into something else that is purely just alpha and numbers? Thank you.

*** EDIT
I can confirm that the commas in the row values were throwing the colors off. I can also confirm:

  • Using Power Query or related to create a custom column with new values stripped of special characters will not work.
  • More heartbreakingly, changing the values within Revit (to remove the special characters) and sending it back to Speckle, refreshing the data and report will not work. While the data is clean without special characters there still seems to be something internal that throws it off.
  • Given this suspicion, I deleted the Power BI report, deleted the project from Speckle and remade/resent the project from Revit to Speckle and remade the report and it works now but then stopped matching after I saved and reopened the project so I don’t know what’s going on.
1 Like

Hey @xyzquestions ,

I created a new thread to keep track of your issue. Can you please share the Speckle Model URL? Feel free to send a DM if you’re not comfortable sharing it publicly.