Some elements from revit does not show on speckle web

Hi everyone! hope you are doing fine

I need some help with revit and the way the objects are send to Speckle
First of all i want to say that the app is amazing and its super usefull (and free), so i apreciate that.

Returning to the issue: When i send everything of the revit model to speckle, i noticed that a particular plumbing fixture did not appear on the speckle web viewer, i tried selecting that element and sending it again but it does not show.

The element is a Water Tank, i tried with other families of water tanks and they also doesn’t show
Im using Revit 2021.1.8
The Speckle Connector for Revit is V2.18.3

Speckle_Water_Tank.rfa (608 KB)


1 Like

I just want to mention that i did try to send the same family on Revit 2024 and it did work, but sadly most of the projects that i have to manage are from older versions, like 2021 for example, and i dont know why it doesnt show on the viewer app

I did check your family, and the problem seems to stem from the family type. I encountered the same issue as you when exporting the data with Speckle. I found a temporary fix for your problem. You can switch the family type from Plumbing Fixtures to Generic Model, and it worked for me. Have you ever encountered a similar issue when exporting Plumbing Fixtures family on Speckle?


I did the same test on Revit 2024. And you are right. Everything work just fine. Seems to be a problem with 2021…


Hey @Gab @NicolasRivero ,

Thanks for sharing your workaround. Have you tried sending from a later version of Revit? We’ve had several issues reported with Revit 2021 that cannot be reproduced in later versions.

1 Like

yes, everything is working great in later version. Thanks.


Hi @Gab and @gokermu ! Thanks for taking the time to test the issue.
I think that the solution you propose is valid when you dont need the family to act like a plumbing fixture itself, for example you dont need the family to be copy monitored on other revit models.

Maybe i will need to make the clients change to newer revit versions, as you also tested on newer versions of revit, this issue does not happen.

Thank you again!