SketchUp model is sent rotated

Greetings! Firstly, I would like to extend my congratulations to your team on the tremendous improvements that have been made to the connector. However, I do have a simple question to ask: Why does the sent model in Speckle appear to be rotated 180 degrees? Although it is not a significant issue, I find myself consistently taken aback by this.


Hi @mircea.stefanescu,

First, thanks for good words! Thanks to community we will support more feature :slight_smile:

Trying to understand issue. Do you have created scenes on your model? Because these scenes should be aligned with the speckle views on viewer. I don’t see created scenes on your model as below sample :thinking:

If you created already, I suspect scenes might not be updated as you wish before send?
Another did you check views on viewer, can you please try to click views on viewer and approve it shows still wrong view?

If all OK, then we should check this is really an edge case or not…

I made a GIF to see exactly what I was referring to. There is no “scene” created or involved in the process. The resulting Speckle view is rotated 90 degree.
Speckle Rotation test

I don’t think we can solve this one… Sketchup’s default view angle is not the same with the viewer’s default view angle. What we could check is see what that angle is across apps (e…g, rhino!) and, if there’s a pattern there, change our default viewer camera positioning (that’s the easiest bit).

1 Like

Hey @mircea.stefanescu ,

I don’t see this as a problem. Sketchup’s default view is different than ours. And that should not be a problem. Just like Rhino, Revit and Archicad has opening camera positions and projections, Speckle also has an opinion on this :slight_smile:.

But what I’d see as a valuable feature would be some sort of “Opening Camera Position” setting in the viewer. I guess we’ll get there at some point. Just not yet :blush: