Sketchup connector not showing up after external screens plugged out

I’m attempting to open Speckle in SketchUp, but nothing is appearing on my screen. Is there a way to reset the position of the floating window? I’m currently using a single monitor, and I used to work with a three-monitor setup before. It’s possible that Speckle is located on another monitor from the previous layout.

1 Like

Hey @mircea.stefanescu ,

Great to see you back! You can right click on the toolbar and check if Speckle is selected. If it is, can you try the following:

Go to Window > Preferences > Workspace and Reset Workspace. They try to enable Speckle from the toolbar dialog again.

1 Like

I thought that no news from me was good news for speckle! :grinning:
Resetting the workspace didn’t do the trick. It looks that there is something else …
I open Sketchup and select an object, I press the the blue cube, then for a “millisecond” I could see the hourglass and then …nothing happen.


Just to clarify, do you see the Speckle Cube in your toolbar? Are you experiencing an issue where the UI does not appear when you click on the cube?

Yes, that’s correct. I am facing the issue where the UI does not appear when clicking on the Speckle Cube in the toolbar. Here are the steps I’ve taken so far to address the problem:

  1. I disabled all other extensions, but unfortunately, it did not resolve the issue.
  2. I attempted to fix it by uninstalling and reinstalling the Speckle connector, but this did not work.
  3. I also tried uninstalling the current version of Speckle Convector and installing a previous version, but this did not resolve the issue either.
1 Like

What happens when you do Alt+Tab? Can you see Speckle window?

:neutral_face: NO - no Speckle window when pressing Alt+Tab …

Ok, can you try the following?

  1. Restart SketchUp.
  2. Click on Speckle Cube.
  3. Without clicking anywhere else, use Windows+Up couple times. It should move the window around, eventually it should show up in your main window.

I hope this helps.

Your suggestion, which came in later, didn’t solve the problem. It’s possible that the issue is connected to the “checked” option in the display settings, specifically the one titled “Remember window locations based on monitor connection.”
I recall encountering a similar issue with another plugin some time ago. That particular plugin had a special option to address the problem. I’ll be back to my usual monitor setup in two days, and I’ll check if this is indeed the case.

Hi @mircea.stefanescu, thanks for reporting this edge case!
This is super annoying. I might find a temporary solution. Can you follow the instructions below?

  1. Open Ruby Console from Extensions > Developer > Ruby Console
  2. Run command SpeckleConnector::SPECKLE_APP.ui_controller.user_interfaces.values.first.dialog.bring_to_front
  3. Hold Windows button + Press ArrowUp

PS: Try not to click or press anything after running the command on Ruby Console because this command ideally activates Speckle UI to maximize the functionality of Windows.

Hope this helps for now

Regardless we must open a ticket for this. @gokermu

Not sure, maybe I have done something wrong, because after running the provided script, the message is:
#<NoMethodError: undefined method `dialog’ for nil:NilClass>

:in `' SketchUp:in `eval'

=> nil


Looks like the problem is different then. Could you open Ruby Console before initializing Speckle on a fresh Sketchup instance? I want to see what’s happening with your initializing.

From this image I have a feeling you didn’t init Speckle before running command :thinking: Because logs should be different in that case

Seems like your plugin initialization process is successful. I will try to reproduce your issue with a second monitor case as you mentioned, and will consider a hotfix.

yep! you are right! My mistake! :upside_down_face:

Then ideally below should work if you run the command after your initialization process :crossed_fingers: Otherwise our problem might be different than the window location issue…

1 Like

Unfortunately, the script I attempted to use was ineffective because the problem doesn’t revolve around bringing the SpeckleUI window to the forefront. Instead, the challenge lies in relocating it to the primary screen from the “virtual space” where it was previously positioned. From my understanding, the issue is associated with the use of multiple monitors. When I connected the laptop to my usual setup, SpeckleUI appeared on one of the monitors effortlessly. However, upon disconnecting the two external monitors, both Speckle UI and the “Default Tray” vanished. Although the “Default Tray” reappeared after restarting SketchUp, Speckle UI did not. This seems to be a unique problem within SketchUp, as I’ve encountered a similar issue with another plugin that offered a reset option. In the future, I’ll ensure to relocate SpeckleUI to the primary screen before using Speckle without external monitors.


Thank you for sharing this with me, @mircea.stefanescu. I will create a ticket for your request. If it’s a simple issue, we will aim to resolve it as soon as possible. However, if it’s a more complex matter, we may need to prioritize other tasks first and you may need to wait a bit longer.