Server-side issues with graphql requests from specklepy

Hi @dimitrie, @gjedlicska,

I’m having issues with some API requests to our company Speckle server (of RHDHV). This happens for a specific stream, other streams I tested seem to work fine. As an example, here are 3 basic requests, where the first two result in a GraphQL error, while the third one functions correctly.

The exact error message is as follows:
Failed to execute the GraphQL stream request. Errors: [{'message': 'The loader.load() function must be called with a value, but got: null.', 'locations': [{'line': 33, 'column': 13}], 'path': ['stream', 'branches', 'items', 1, 'commits', 'items', 0, 'authorName'], 'extensions': {'code': 'INTERNAL_SERVER_ERROR'}}, {'message': 'The loader.load() function must be called with a value, but got: null.', 'locations': [{'line': 33, 'column': 13}], 'path': ['stream', 'branches', 'items', 1, 'commits', 'items', 8, 'authorName'], 'extensions': {'code': 'INTERNAL_SERVER_ERROR'}}]

This seems to be happening server-side, but I don’t know what is happening exactly. I did notice that you released a new version of the speckle-server repo yesterday, which also seems to be deployed directly to our Speckle server (now at version 2.14.3). So probably this release has introduced a bug that results in above errors, but only for this specific stream (as far as we know now).

Could you look into this issue?

1 Like

Hey @Rob,

could u check with Pieter about the status of your firewall blocking the Cloudflare IP?

I tried to reproduce your issue with the devops user on your server, but things worked on my end.
If you are unblocked, could u share the stream with the account, so that i can take a look?


Thanks for your response, we’ve just added you to the stream as contributor, let me know if you need admin access.

I also sent Pieter a message, but don’t know about the firewall status yet. You should be able to reproduce the bug now though. As in my previous message, you could try:'14ddd6955c'), or

and maybe more requests are failing. However, I’m assuming that they have a similar or same root cause.

1 Like

Hey Rob,

thanks for sharing the stream, I can repro your issue on my end. We’re investigating the issue. I’ll get back to you.


Hey @Rob, we’ve been able to identify and fix the issue. It was a server side potential regression from our last release. A fix should land soon :tm:

Thanks for your help :slight_smile:

1 Like

Great, thanks!
Will confirm once it works again from our side.

Fix should be live :slight_smile:

Hereby confirmed! :smile:

1 Like