Sending of ETABS Pier and Spandrel Results Not Completing

Hello Speckle team and community!

Re: Sending of ETABS Pier and Spandrel Results Not Completing

For a current workflow, we are investigating the sending of ETABS results using the Speckle for ETABS connector. The invesitgation is aimed specifically for wall output (pier and spandrel forces).

A summary of investigation and what was noticed:

  • A simple model was created in ETABS (with appropriate Pier assignments)
  • Model was run with just a Dead load case
  • For the Data Exchange: SelectionCategoriesPier
  • For the Advanced Settings: all analysis results were set to be sent
  • The send takes a very long time - currently over an hour on my end before I cancelled the operation (i.e. not completed).

Screenshots from the above mentioned worklflow:

Any help would be much appreciated. Thanks in advance! :slight_smile:


cc: @AlexHofbeck @ltascheva

1 Like

Hi @bjoernsteinhagen,

If you are interested in pier and spandrel forces, I would check only the 1D analysis results. The 2D analysis results in particular can be massive (we’re essentially sending all results at every node of the FEM mesh for every load combo). Let me know how that goes for you.

Currently we’re sending all the results that ETABS will give us which is almost so much data that it’s not super helpful. Adding some abbreviated analysis results is high up on my list of todos for the connector.


Thanks @connor. Trying that now with only the 1D analysis results checked :slight_smile: Will let you know how that goes.

Hi @connor. Changing the advanced settings to only Send 1D Analysis Results unfortunately didn’t prove to be a quick fix. The Send tried running for over an hour.

The model was further simplified as follows:

  • One wall elevation with pier assignments
  • Only 8 entries of pier forces to extract / send
  • Advanced settings as mentioned above
  • Selection again as: CategoriesPier

After this I then cancelled the send. An interesting observation though, when I changed the selection to “Everything”, the Send seemed to work (i.e. it completed). However, when interrogating the commit, the AnalysisResults seem to be poppulated with nulls / aren’t to be seen.

Also, when searching through the Report for created objects, the keywords for Result doesn’t appear. (e.g. Objects.Structural.Results … )

Am I missing something here? :slight_smile:

Kindest regards,

1 Like

Hmm that is strange. Step one is to make sure that your model has been run and actually has analysis results. Assuming that is the case here, this requires a bit more investigation. Which version of the connector are you using?

Always a good thing to check! :slight_smile: Referring to the first screenshot in the first post, the model was locked and the pier forces table showed appropriate results.

Just to double check, I re-ran the model and tried the Send again, without any luck.

I am using Speckle for ETABS v2.12.2.

I am not sure if anyone has tried this workflow / experienced the same issues? You can find the simple model attached here.

einfaches Modell.EDB (92.6 KB)


Hey @bjoernsteinhagen

Thank you very much for sharing the file with me. I found a pesky null reference exception that occured when only sending results for some elements instead of all of them.

It should work if you install this newest version. Let me know if this works for you


Hey @connor

thanks for your response! I downloaded the 2.13.0-alpha2 version and tested the same thing out. The ETABS Connector now shows an entry for “AnalysisResults” being created :smiley: !

I am however struggling to see how this can be accessed on the Speckle Stream (online). Results don’t show up on a element property (e.g. when selecting a wall) or when navigating through Data View > Analysis Results > results1D (see below picture). I fear I may be missing something simple here (if so, sorry in advance :sweat_smile:).

I am anticipating to somehow expand a table view online, similar to Tables in ETABS.

Thanks in advance!

Kindest regards,


Hi @bjoernsteinhagen,

It looks like the CSI api is only giving me results after I hit the “Start Design/Check” for the desired elements. Are you doing that? If not then could you give that a shot?


It’s a bit confusing how after just hitting “Run” the api isn’t giving any analysis results even though you can view them in the tables so results are clearly availible. I am going to investigate this further.


Hi @connor,

Thanks for the response! No, I didn’t hit the Start Design/Check in ETABS, as I am looking to run design checks for piers outside of ETABS (in verified design spreadsheets). But I’ve tried that out now and I can see Pier Forces now after hitting the Design Check in ETABS.

Correct, it is a bit confusing. It would be cool if we can avoid having to do this step of design checks in ETABS.