Rhino toolbar not showing up


This is my first time testing Speckle connectors and I’m having an issue with the Rhino connector.
I successfully installed the connector and I can run ‘Speckle’ command in Rhino to export/import models.
But I can’t load the toolbar to access Rhino BIM features. I’m trying to tag elements in Rhino with Speckle BIM tags and import them into Revit.
I followed the documentation to add the toolbar, but there is no Speckle toolbar. Please see below screenshot.

I used the installation file to manually installed the connector and tried both 2.4.0 and 2.4.3 beta version but not working. I tried uninstalling and reinstalling.

Any advice would help! Or if there’s a way to tag Rhino elements without the toolbar, please let me know.

1 Like

Hey @soojungkim , welcome to the community!

We’re actually right in the middle of figuring out this toolbar bug, and hopefully that will be fixed in the upcoming beta release.

In the meantime, you can use commands like CreateFloor, CreateBeam, CreateAutomatic etc to tag your elements! You can refer to the docs (Rhino | Speckle Docs) for the full list of supported elements :slight_smile:

1 Like

Thanks for the quick response @clrkng !
Those commands worked without the toolbars as you said.
Thank you!


Hey @soojungkim, the Rhino connector for Windows should have the tooldbar staged and visible on install with the upcoming 2.5.0 release - this required a renaming of the toolbar file, so let me know if you are experiencing any conflicts with the old installation when you update :slight_smile: