Rhino to blender creates nonmanifold edges and geometry

When importing projects from Rhino to Blender it creates nonmanifold edges and I’m not sure how to fix it. I’m fairly new to Blender, so I’m not sure if there is a way to fix the edges or not.

Great question.

Geometry coming from Rhino will often be non-manifold. Our geometry conversion tends to avoid changing your vertex data unless its necessary. Hence, you get non-manifold edges Rhino → Blender.

When you receive, we offer a “Clean Mesh” option, that will merge the vertices for you (plus a couple other operations, see docs )

But if you’d prefer to do it manually, you can select the meshes, press tab to enter Edit Mode, and merge vertices by distance (Merge → By Distance)

You could even do this on the Rhino side I believe by welding the edges.

Hopefully this helps