Rhino Plugin Comments & Feedback

Let’s get this cracking! We’ve got an (almost) usable plugin, now let’s hear it:

  • UI improvements
  • UX flows
  • Bugs/Features
  • Heads up
1 Like

Hey Dimitrie…
initial tests on the RhinoSpecckle and other than it is GREAT! a coupe of really small comments regarding the interface:

  1. When adding a receiver, the drop down menu of your streams shows the oldest first and the newest last… shouldn’t it be the other way around? useful for when you have some 200 streams to your accoount!
  2. Being able to snap directly to the Speckle Geometry in Rhino would be really helpful!
  3. You can now hide the objects in the Streams individually but it would be great to be able to hide the Stream as a whole

First few comments, more will follow as we start getting our teeth into it!


Yes - noted. You’re right. If you’ve noticed, in the accounts panel this already happens :slight_smile:

I dream of this. I’m not sure if this one’s easy… @luis had an earlier version of this (last summer) in which there was automatic baking going of the “real” objects, and you could snap to those. This added though some “jank” and we decided to go for a more gh-like approach.

Actually you can! Doubleclicking on a layer’s visibility icon will toggle all of them on/off. Though yeah, this might need to rethought.

1 Like

Thnaks for the quick reply!
I thought that snapping would have been somehow “messy” what you have see in Rhino is only the render mesh not the “real” object right?
Maybe the edges only of the obgect could be brought in to allow some limited snapping functionality? or maybe I’m talking out of my a**…

I’ll wait for @luis for this one. Though just edges - maybe could be snappy. Anyway, as it is now, the “hover” effects and stuff on the display conduit are rather slow. There’s plenty of optimisations that need to happen…

Is there a way currently in Rhino to write to an existing stream? For example, I created a new sender yesterday, added some object to the stream, and today I want to continue changing things in the same stream. I don’t see a way to select an existing stream when creating a new sender.

Or is there a reason why this workflow is undesired, and really I should be using some other workflow?


Well, if you open that rhino file again, it should have the sender stored. You can then add/remove/modify objects from the sender using the super intuitive speckleUi™.

Existing sent objects are tracked, and if you change them in any way, the stream will update!

Speckle doesn’t allow (yet) modifying senders from multiple locations/sources. So if you want to modify an existing stream in a new place/file, just bake the contents from a receiver and make a new sender.

Hi there,

My colleagues and I have experienced some issues with the Speckle Rhino installer and cannot quite figure out what the problem is, as it did work for some of us but it did not quite work for others (all Rhino 5, 64-bit). We were using the latest built from github and none of my colleagues had a previous version of Speckle installed. However, when restarting Rhino after running the installer, the following error message popped up:

In the other cases, in which the installation worked, the Speckle panel only did not show up in the panel listing. However, it was possible to open it via the command line.

I also gave one of my colleagues with a non-functioning installation the previous built (still Speckle 1.0.0, release Feb 2018) and it then resulted in this:

It did then install the Speckle Grasshopper plug-in, but not the Rhino one.

Any advice on how to fix the installation would be highly appreciated. Speckle is really amazing and we would like to use and test it more extensively across our team! :smile:

Hello! I’ve tried to reproduce the issue, but have not succeeded. I installed W10, Rhino 5x64, and SpeckleRhino from https://ci.appveyor.com/api/projects/SpeckleWorks/SpeckleRhino/artifacts/specklerhino.rhi?branch=master&job=Configuration%3DRelease.
Speckle loads fine in Rhino 5.

You could also go to Tools → Options → Plug-ins. Right click on Speckle and select ‘Load plug-in’.

My only suggestion now is quadruple check that there is no file that has anything to do with Speckle on the machine, and then reinstall specklerhino.rhi. There could be several places these files could be, including:

  • C:\Users<username>\AppData\Roaming\McNeel\Rhinoceros\5.0\Plug-ins
  • C:\Users<username>AppData\Roaming\Grasshopper\Libraries

Barring any of that working, we can set up some sort of session (maybe on slack) where we can go through things bit by bit to see where the problem lies.
Let me know!