Rhino Crashes when starting speckle

Rhino will hang and ultimately crash when I click the Speckle button on the toolbar, i’m signed in, so it’s not relating to this issue Rhino crashes when using Speckle - #11 by dimitrie
Crash log says:

[ERROR] FATAL UNHANDLED EXCEPTION: System.ComponentModel.Win32Exception (0x80004005): 配額不足無法處理此命令。
   於 System.Windows.Interop.HwndTarget.UpdateWindowSettings(Boolean enableRenderTarget, Nullable`1 channelSet)
   於 System.Windows.Interop.HwndTarget.UpdateWindowPos(IntPtr lParam)
   於 System.Windows.Interop.HwndTarget.HandleMessage(WindowMessage msg, IntPtr wparam, IntPtr lparam)
   於 System.Windows.Interop.HwndSource.HwndTargetFilterMessage(IntPtr hwnd, Int32 msg, IntPtr wParam, IntPtr lParam, Boolean& handled)
   於 MS.Win32.HwndWrapper.WndProc(IntPtr hwnd, Int32 msg, IntPtr wParam, IntPtr lParam, Boolean& handled)
   於 MS.Win32.HwndSubclass.DispatcherCallbackOperation(Object o)
   於 System.Windows.Threading.ExceptionWrapper.InternalRealCall(Delegate callback, Object args, Int32 numArgs)
   於 System.Windows.Threading.ExceptionWrapper.TryCatchWhen(Object source, Delegate callback, Object args, Int32 numArgs, Delegate catchHandler)

配額不足無法處理此命令 can be translated to something like not enough allocation to execute command, sound like not enough RAM for something, but when viewed with task manager, Rhino is barely using any RAM.

Dump file is here:

This only happens on this one laptop I have, tried reinstalling both Rhino and Speckle, but still the same problem.

Any ideas?

Hey @lin-ycv ,

Sorry to hear about this issue, can you please confirm :

  • are you using Rhino 6 or 7?
  • what version of the Speckle Connector are you using? It should be 2.9.2, if not, please try updating it

Hi @teocomi, thanks for the fast reply

I’m using Rhino 7
I’m away from that laptop right now, but I made sure to download the latest version from the manager, if 2.9.2 is the newest then yes that’s what I’m using, unless there’s been an update since last Friday.


Hey @lin-ycv ,

That’s the most recent version, so it sounds like something is wrong…

  • did Speckle for Rhino ever work for you before, or is this the first time you are using it?
  • do you have any other Rhino plugins installed?
  • did you try any other of our connectors (Revit, Grasshopper… etc)?

note sure what happened, but the laptop had some wifi issues, sent it in to a shop and had it fixed, just got it back, now speckle works fine.

I think the issue is related to speckle not being able to connect.


Thanks for reporting back :slight_smile: we’re aware the “offline state” needs improvement and will tale care of that asap :slight_smile: