Rhino 7 failed to find local view

Hi Speckle community,

Any idea why I can’t send any geometry (points, lines blocks) using the Rhino 7 connector?

Everytime I get this error “Failed to find local view…”

This is my first time using it in Rhino 7.

It’s worked fine in grasshopper

Hi @Joe_Landers, what version of the connector are you using? Also if you could pass me a copy of the file with the geometry you are trying to send, that would be helpful!

We are currently testing our 2.2.4 beta release which includes a few bug fixes, the “failed to find local view” is a misleading error message that will be improved (it means the guid of the object you have stored in your selection could not be found in the doc). Could you try clearing your selection, reselecting your objects, and then sending again?

My Rhino connector is 2.2.2

I’ll send you link via private message. Can you get any of the geometry to send?

Also I should note that this was a file setup in Rhino 6, then opened in Rhino 7, and then saved as a Rhino 7 file. But I can’t even seem to get it to work for a brand new Rhino 7 file and objects

Updating to the beta version of the Rhino 7 connector (2.2.4) solved all the issues. I can now send any of my geometry (points, lines, blocks) from my Rhino 7 file to a Speckle Stream. Thanks for quick reply to resolve.


@Joe_Landers glad to know the latest release fixed your issue! Do note that 2.2.4 is still a beta release so if you find anything else that doesn’t work please let us know!

We’re currently testing it to make a stable release that will be going out in the coming days.

1 Like