Revit won't fire up Speckle

Hi all,

I’m encountering an issue where Revit 2022 won’t start up a new connector window:

Edit: Revit 2021 is working fine by the way

Any ideas?

1 Like

Can you show us what’s under “show details”?
Guess you’re on the latest version right?

Of course, sorry, was a bit in a hurry yesterday, so the post was a bit hasty.

Somehow it works today!
I’m running Revit 2022.1 and on the speckle Revit connector 2.6.4.
Discussing it with a colleague yesterday it was something about the window not being created before stuff was being added to it? It said something like that in the details.

Sorry, since it’s working now, I can’t reproduce the error :laughing:


I am having this issue too… I can’t get it to work and tried for 2 days now. Uninstalling, restarting, re-installing, trying previous versions, tried different versions of Revit…

Here is my screenshot.

Hey @Fubar - sorry to hear!
Have you developed anything Speckle-related that might conflict with our release? Or maybe installed another plugin that might be using Speckle behind the scenes?

I’d suggest looking in these locations and deleting any Speckle related folders, then reinstalling the latest version:

User Addins:

Machine Addins (for all users of the machine):

Addins packaged for the Autodesk Exchange store:

Autodesk servers and services:
C:\Program Files\Autodesk\Revit 2016\AddIns\

Let us know how it goes!

Just deleted EVERYTHING in all those file locations, reinstalled the newest version via the speckle manager and same thing. Probably lost some really useful addons in the process but I wiped the slate clean and only installed speckle to get the proper diagnoses and still having the error. The speckle window is opening completely solid grey.

Oh no, sorry to hear this @Fubar !
We’ve not seen this before, and we cannot replicate it on our end, so it’s quite tricky for us to understand what’s happening…

Some more questions for you:

  • any chance you have Visual Studio installed, and we could try to debug it together?
  • what versions of Revit have you tested with?
  • am I correct to say that the error went away, and now you just see a grey box?

Yeah, I think I do have VS installed. and would be happy to debug it with you.

I have 3 versions installed. 2021-23
The error only comes when I try to push a button in the ribbon. If I just load Revit, the Speckle window opens grey.

Thanks for your help in solving this, sending you a PM now :slight_smile: