Revit to Blender - Creates Duplicates in Blender

Hey @jonathon
I have used 2.16 and 2.17 both.

Oh, why?

Why not 3.6 LTS (?) stable or even Blender 4 official ?

@zoomer does an upgrade to 3.6 help @Pankaj_Prabhakar with his issue?


There can be many reasons why not to upgrade, plugin support is one of them at least

Hmm, this is weird. We have used 2.16 version in the tutorial. I’ll test this tomorrow morning and get back to you @Pankaj_Prabhakar . Thanks for your patience!

1 Like

I have no clue but higher numbers are better ?
Was just kidding,
but I think that beside new features, it is likely that more of older long
time bugs are meanwhile fixed also. As Blender costs are neglect-able,
not updating and go with current versions must have other reasons.
Also I would expect that Speckle concentrates more on more recent Blender
versions for their Speckle Support.

I just wondered as 3.1 is back quite some time.

But I take back my 4.x recommendation, as the files are no more compatible
for exchange with older versions.

I could imagine, if Blender 3.1.x was also already an LTS version and
e.g. working on a long time project (Film, Game, …) keeping the project in
the same (LTS) version and not migrating to the newest is a very pragmatic
and professional decision.
Or maybe with hardware limitations an older version may be better.

My personal experience with OSs or Apps is that I risk mostly working
with Betas or even Alphas and have less problems with these than with
matured release versions that already have 4-6 Service Packs/.x numbers.
But that is no recommendation or professional behavior …
As I am on Apple Silicon I also want the latest versions to finally get full
Apple ARM support for my Apps.

Hi @Pankaj_Prabhakar!

I was able to reproduce the error you reported🥹. Since it’s nearing the end of the year, most of our team members are currently away enjoying the holiday season. We will definitely get to the bottom of this once everyone is back. I promise to keep you updated on any progress we make, so you’ll be in the loop the whole time.

I really appreciate you taking the time to let us know about this issue, and I want to thank you for your patience and understanding while we work to resolve it.


I have used them but they also not working?

No, Upgarding Blender as well as Revit didn’t help.

Hi all, I got the same problem. Waiting for the solution. Thanks a lot!


I just came across this issue (I’m pretty new to speckle) and was wondering if there are any updates, like other things to try or an expected fix date.
One thing that I noticed was that in the tutorial video he selects “blender” instead of “main” (at 10:23) but I only see an option for “main.” Is that what everyone else is seeing on their devices?

1 Like

I can’t offer you a fix date at present, we have it registered in the action backlog. Other tasks have taken priority since it was reported, but we have logged that we can replicate it, making fixing it more straightforward when it comes.

Hey @Stavson ,

Welcome to the community! Feel free to Introduce yourself :person_gesturing_ok: to the community if you want to! :grinning:

That was a model (branch) I created. You can create a model (branch) and name it whatever you want.

Just wanted to add to the discussion that our team has been eagerly awaiting this update for Blender as well. I also had issues with duplicates going from Revit to Blender and wasn’t sure if it was user-error or something else. I’m glad to see that it was reported already.

We have dozens of technicians and project managers continuously making updates to Revit files, so having the ability to refresh the model in Blender while retaining materials is extremely beneficial. We all appreciate the attention Blender is getting with the Speckle team! Thanks!

1 Like

@jonathon @gokermu @Jedd
I’m guessing the issue is related to this task posted in the Rhino forum: Rhino to blender not updating mesh but creates a new one - Help - Speckle Community

If so, would it be possible to get around the duplicate name/collection issue in the Blender connector by swapping the mesh data block on existing geometry instead of deleting the object entirely and replacing after appending “.001”? Blender allows this via the GUI (see attached screenshot) but I’m not sure if it’s possible via code?


Not sure how this affects instanced objects/data, however. With a quick test, seems like it allows just one object in an instanced set to be swapped without impacting the others.

1 Like

Hey @mseawell ,

Thank you so much for taking the time to look into the issue and sharing your findings with us! I wanted to let you know that we are working on improving our Blender connector’s update behavior, so you won’t have to worry about duplicates in the future. It’s taking longer than expected, but we’ve had some significant technical changes in previous releases that have affected this feature. Thank you for your patience.


I am new to here, but I like what you are doing.
Tried and experiend same error in Blender.
When fixing that issue, maybe one thing might help for export. Please use Typ and Intance naming for all items. because this will help to differtiate when getting those in Blender.

Thank you for developing Speckle!

1 Like

Could you elaborate on that for use @HeinrichBoldtGetinge - it will help non-blender users describe the request better for those working on that connector.

And welcome to Speckle !!

1 Like

Hi Jonathan
maybe a model will help more.
for that I have placed 2 Families with different types.

and here is the link to the speckle.

as I see on the screenshoot, the namings are there. but in Blender it will not convert on the namings of the elements. but that could help a lot for working in Blender further with that model.

working in Revit, to make movies based of a Layout in Revit I would like to point to another method of linking parts of Elements.
maybe that video will help to get the understanding of the way, objects can be linked bo using the same items

this is someting similad in Revit, the Types might be equal on type parameter level, but there are some differences on the level of item.
maybe now I got to many ideas mixed. but hoppefuly this will give more clearance. if you have more question, feel free - I have many years experience in Revit and developing many families.

Heinrich Boldt

1 Like

I get it, thanks. I was thinking where in Blender you were looking to see Type and Family data/names.

Blender doesn’t know anything about Revit, and Speckle might be hosting data from other sources; we need a mechanism to see what you want to see where. The Blender Object tree?

I understand what the video shows, but I’m unclear on how this relates to the naming issue.

I am also new to Blender
maybe I have missed something. but I cant identify the types.

I can also make the Link free so you can play with that file for importing and testing the best way.

here is a screen shoot out of blender. the namings are only on Family_Level

1 Like