Revit Spaces/Rooms Exceed Roof/Ceiling


Yes the previous small model I sent has spaces.

When importing from Revit spaces are visible but for some reason are not limited to the roofs as they should be.

I have never managed to import spaces from ifc model

1 Like

Gotcha (also thanks to you all for the help so far!).

That’s a revit connector issue most likely! I’ll need some help from @gokermu to split this thread up (cc the connectors team too). Again, as always, the file would help massively.

Well, let’s see what i can do. I’ll try to carve up some time towards the end of the week to look into this!


Hi @ElsaK :wave:,

This is due to how the default option in Revit calculates Rooms and Spaces’ volumes. They are basically a boundary extruded in the Z direction with a specified height. If you don’t want your rooms to go beyond the Roof/Ceiling height, then change the Area and Volume Computations in Revit👇.


Rooms sent using the default calculation

Rooms sent with Volume Calculations

Hope this helps.


Many thanks for your advice :slight_smile: