Revit - Power BI

  • Objective: I want to send all my structural elements from a highrise tower to Power BI to visualise the concrete and reinforcement parameters

  • Issue: I have filtered 10,000 elements from the model and send them to Speckle. When I receive this data in Power BI it is very slow (takes 30+ minutes to bring in the data) and brings in all parameters associated to all Speckle categories. Is there some best practices to only be filter the data before it gets into Power BI.

  • Example: See attached screen shot from speckle

thanks, Matt

1 Like

Hey Matt,

Currently, there is no setting to control/exclude parameters that are being sent. How would you see that being implemented or working?

We have recently introduced a “Level of detail” option in the “Advanced Settings” in Revit; changing it to medium or draft should definitely make sending and receiving faster.

Let us know if it improves things for now!

Hey Matteo,

thanks for getting back to me. I used the “coarse” setting in the last upload, which didnt seem to make a difference unfortunately.

With Bimbeats, our snapshot tool, allows the user to specific which categories and parameters to send to elastic, when we sent “everything” it contained 90% of parameters we were not really using. So maybe a UI which allows the user to specify a template or list of categories and parameters could be an option.


Hey @BIM_Wash ,

Great feedback. We’ll create a ticket for this. In the meantime, as a workaround, you can try the following:

First, receive your Revit data in Grasshopper. From there, extract the geometry and only the parameters that you’re interested in. Then, create new speckle objects using those two inputs and receive that in Power BI.

Please let us know how this workaround works for you.

1 Like