Revit Pipes look block-like, uncomplete (mesh)

Hi, I am trying to use speckle to push pipenetworks from Civil to Revit.
The sending from civil to the speckle stream works well and the pipes aswell as sludge collectors look good in the speckle viewer (see images attached). However I have trouble receiving the pipes in the Revit model. Either they aren’t importet entirely or the appear block-like, uncomplete (see image attached). I did try with mesh-import and without it and the problem seems to be the same.
It’s my first time using speckle and maybe it’s a small mistake on my part (wrong options ticked, or wrong display type maybe) however I haven’t found a solution yet so this is my last hope :wink:

Thanks for your help.

Hey @EdwinB, welcome to the forum! Feel free to introduce yourself if you’d like!

Thanks for reporting this issue! Would you be able to share the Speckle commit that you are trying to import into Revit. You can do this either by making the stream public and sharing a link to it, or by adding me (Connor Ivy) as a collaborator. If there are intellectual property restrictions or something along those lines then maybe you could create a new commit that just contains the pipe networks?

once I have access to the Speckle commit that is failing to import correctly, I can find why it isn’t importing correctly and try to fix it :+1:

1 Like

Hi Connor, thanks for your response. I added you as a collaborator. The Data isn’t confidential due to it being a school project so it’s a fictional site.

Thanks for taking a look at it, I really appreciate it


Hi Connor

Were you abel to take a quick look at my problem?
Let me know if you need anything else from me.



@clrkng is currently working on a sort of overhaul of pipenetworks in Revit, so we will have better support for those in the near future. The mesh-import option should be supported so it’s concerning that that doesn’t work. While I look into that, would you mind elaborating on your use-case for civil → revit?

Are you trying to get the pipes as family instances in Revit or would just having mesh representations of the pipes be enough for what you want to do?

Alright that sounds good. I’m currently working on my bachelor thesis project and I wanted to showcase a use-case to import the pipes from civil into revit. They didn’t have to be displayed as a specific family type but if that would be the case - even better. I was just trying to get the geometry of the pipes into revit to check for any clashes with potential tree planting sites. It would be beneficial if they were displayed as actual pipes (round) and not in the way it does in my first post.

Thanks a lot for your time

Hi @EdwinB @connor ,

The missing pipes need investigation, but the reason why the successfully created pipes appear with a different shape in Revit is most likely because the pipes from Civil3d are assigned a default Revit pipe family when you receive them into Revit. Currently, this is the expected behavior in Revit for all MEP elements that did not originate from Revit or a Revit Grasshopper component.

It sounds like you want to receive the actual displayed mesh of the pipes (eg what you see in the web viewer) instead of using the default native revit pipe family and receiving them as instances of that family. There are three current options here:

  1. select the pipes you received in Revit and manually change them to a matching family type
  2. (new feature request) we’ll have to add a receive setting in Revit to receive the display value of objects instead of creating native family instances
  3. (currently wip feature) use the mapping tool in Revit to select the desired family type for the pipes you receive

If you feel strongly about the 2nd option we can discuss internally and see if this would make sense to implement!

1 Like