Revit model (commit) in Speckle not updated / replaced

Hi All!

I am needing some help with what I can assume an easy to solve but complicated for me issue!
I do apologize if the question has been asked and answered before. I did find a similar question before, but I did not understand the solution.

I have create a stream in Speckle and sent my first Revit model creating a commit I believe.
I updated the model and did two tests, one where I sent the entire model again to the same branch and another where I only send the item that was updated to the same branch.

But it created two additional commits instead of updating the existing model in the branch.

I tried to look for a way to manually add the updated item to the first commit and could not find something like that.

Is there a tutorial some where that I can watch or read to explain this in detail?

Best Regards!

Hey @ShaneJAM ,

Welcome to the community! Feel free to Introduce yourself :person_gesturing_ok: to the community if you want to! :grinning:

First, I want to let you know that we renamed our core concepts. Streams are now Projects, Branches → Models and Commits → Versions.

Whenever you send your data to Speckle, we capture a snapshot of your current state and upload it as a Version or Commit. Think of it like Google Drive, where uploading a file with the same name replaces the previous version while still retaining the history of the file. However, instead of files, we work with Models (Branches) that are sent through our plugins. This allows you to easily go back to a previous version of your model whenever needed.

In your case, there is no issue. Each card on the screen corresponds to a Version(previously named Commit). The confusion arises from our old front-end. I recommend using our new front-end at Hopefully it will make things clear for you.

Thanks @gokermu !

The link to the latest front-end fixed it!

1 Like