Revit - External Tool Failure (version 2.11.1)

hi @teocomi,

I have installed Speckle version 2.11.1 for Revit 2022 (version 2022.1.3) and Navisworks.
Whenever I tried to open Revit this message pops out


The stream works from Naviswoks, I can’t even make Speckle 2 tab appear on my Revit. Shall I use an older version that can also work with Navisworks, or is there something I need to check further?

Thanks for your help,

1 Like

Hi @cr.aecom is it possible that you have installed an older version of Dynamo or maybe have some other development versions of Speckle loaded in Revit?
Or maybe you have previously installed the Revit connector manually as system-wide?

Reading the error message more carefully, it also seems that maybe this is due to a conflict with other Revit plugins using the Revit.Async package…

hi @teocomi ,
thanks for the quick response.
Yes, I tried to install it as manual download from the website (Speckle Manager triggers my IT system and blocks it, I can install it with the manual installer).
I installed a Speckle version a month ago, but I uninstalled it before doing all this.

I’ll try to uninstall and delete everything. Shall I also do the same for the Speckle Manager or that doesn’t affect the connectors?

Thinking about the last point, what could be apps that are in conflict with Revit.Async package? I have installed lots of them, if you knew any know ones that causes conflicts, I can exclude them.

Thanks for your priceless assistance on this!

update @teocomi @gokermu,
I tried to install from scratch Speckle Manager with Connector for Revit 2022 and Navisworks, the Revit one still doesn’t work. I installed both through the Speckle Manager now. Is there anywhere on my hard drive that I shall manually remove for the uninstall task (maybe some temp or .dlls kept?)

The error still the same so I might suspect is a plugin conflicting…
I have following plugins installed, which shall I try to remove according to you?

  • PyRevit
  • Rhino.Inside.Revit
  • RF Tools 2022
  • RVT Room Link
  • BIM Collab
  • BIM Interoperability Tools
  • Avail
  • Diroots
  • Twinmotion
  • Enscape
1 Like

Thanks for update and sorry for the trouble!

Full cleanup

To perform a full cleanup, you should:

  1. Close any software (maybe by rebooting the PC)
  2. Uninstall the Dynamo & Revit Connectors from Manager (no need to remove Manager itself)
  3. Checking under Programs & Features to ensure they also have been removed from there
  4. Check in the locations below to see if there is anything remaining:

Speckle for Revit is installed in these locations:

  • %appdata%\Autodesk\Revit\Addins\20XX\SpeckleRevit2 (when installed via Manager)
  • C:\ProgramData\Autodesk\Revit\Addins\20XX\SpeckleRevit2 (when installed manually system-wide)

Speckle for Dynamo is installed in:

  • %appdata%\Dynamo\Dynamo Revit\2.XX\packages\SpeckleDynamo2

Checking for conflicts

If instead, we suspect this might be a conflict with another plugin, you could search for the a file named Revit.Async.dll in the various adding folders:

C:\Program Files\Autodesk\Revit 20XX\AddIns\

Let me know what you find! Otherwise we can schedule a quick call and check together…

1 Like

hi @teocomi,
there was a small little nasty addin (ClashNavigator) that was conflicting. Works like a charm now. Thanks for the troubleshooting, it’s insightful to understand which dependencies to check on deployment phase!