Revit connector stops working and shows a black window

hi

for some unknown reason, Revit connector has stopped working. Instead of having a menu, a black rectangle appears and then Revit crashes.

anybody has a clue?

Hi @yien, this looks… unexpected. We haven’t seen this before. Could you point us to which Revit version you’re using? It definitively looks like a graphics card issue/drivers/etc. in relationship to WPF.

I assume it worked before? What did you do prior to this happening?

Revit 2020 (20.2.30.42) and 2021 (21.1.21.45)

on my own laptop is still work, but not my office PC. it worked flawlessly yesterday.

We didn’t push any updates from yesterday to today, so not sure what’s going on.

If a reinstall of the connectors and a restart of revit don’t sort it out, we could jump on a 15 min debug call tomorrow if you’re up for it - let us know! (it’s late here for us)

1 Like

hi did only install Rhino 7 yesterday.
bu i will try to remove and reinstall the connector.

thank you

Hi!
I have the same issues. Not sure when it started, but at least 7 days ago.
It occurs both in both 2.1.1 and the one before.

@yien. Did you play around in the source-code? I did…
I tried to build the Speckle-sharp solution, but it didn’t succeed. Is it possible that the unsuccessful build scattered some bad files here and there?

Here’s a recording of what is happening.
I start the speckle-pluging. Nothing happens. I start it one more time, then the black box occurs. If i click inside the black box, Revit crashes.

I’ve reinstalled all connectors and it still occurs

hi John,

nope i did not touch the source code.
i have the same black box and crash on the Pc with Revit.
Uninstalled every connector, reinstalled. same thing.

but i manage to use Speckle on my laptop instead (revit connector) and on my office pc (Rhino connector).

Y

Ugh! Nasty bug…
Since you already have a Visual Studio installed @John_Haddal_Mork would you be available for a quick debug session next week?

I really tried reproducing this today, and it baffles me :smiley:

One last shot - if you go to Speckle Manager’s settings and you toggle “beta versions of connectors”:


Then update (a refresh might be needed), does this still happen?

I will try now to check if revit 2021 has any pending updates on my machine.

I’ve also just released a v2.1.2-beta of the Revit connector, which includes some updates to the UI libraries.
If you can, please give that a try too!

1 Like

Thanks!

I now tried:

  • Turn of the beta mode and install the latest available
  • Turn on the beta mode and install the 2.1.2-beta. Still same issue

I’m installing the Revit 2021.1.2 hotfix now, I’ll let you know if that fixes the bug

@teocomi : Yes - available for a debug session :slight_smile: I’m more or less available from now till Wednesday afternoon

1 Like

Same issue after the Revit hotfix

doesn’t work for me :frowning:

Thanks to @John_Haddal_Mork we’ve figured that, at least in his setup, the problem was Rhino.Inside.

@yien do you have Rhino.Inside installed as well?

We’ll look into a solution, but the only current workaround is uninstalling Rhino.Inside.

2 Likes

Thanks a lot for the help, @teocomi !

i uninstalled Rhino Inside…and it works.

Thank you both!

Quick update from us: we are investigating the issue and there doesn’t seem to be a quick fix, unfortunately. The only workaround at the moment is to uninstall Rhino.Inside.

We’ll look into how to address this internally and might reach out to the McNeel team and as well.
Will keep you posted, here’s the Github issue for reference.