Receiving Revit objects exteremly slow

I’ve created a very simple Grasshopper setup that takes two cubes, splits it it into walls and roofs and creates Revit objects. So far so good. The problem is when trying to receive them in Revit. It works, but takes upwards of 5-10 minutes for Revit to load this very simple geometry. Is this a know bug or is there something else going on.


Hi @dwastberg!

This seems quite weird. Could you share the stream you are receiving from Revit? I’ll check if I can reproduce this behaviour in my computer with the same data.

Thanks. Here’s the stream: Speckle

Also @dwastberg to help us further, could you tell us what version of Revit and of our Revit Connector are you using?

Revit 2020.2.5
Revit Connector

Thanks! I just tried both on Revit 2020 and 2022 and it only took a few seconds on my end…

While receiving, the progress bar should be showing something like “remote transport…” or “conversion…”.
During which operation does it seem to be taking most of the time?

If it’s the “remote transport”, then it sounds like an issue with your network, if “conversion” it could be your Revit installation or local machine…


Just checked “Conversion” is what’s taking all the time. Although now it ran in ‘only’ ~90 seconds so faster than yesterday, so something might be going on on my end. Once loaded everything runs perfectly.


Thanks, maybe it was a temporary glitch!
90 sec is still much slower than on my end but it might be simply down to computer speed, as the bottleneck here is the Revit API…

If it happens again I would suggest trying disabling other Revit addins and seeing if anything changes.

I just tried with a larger and slightly more complex model and now the Revit Receiver is stuck on DS: 221. I don’t know if that is more helpful

Thanks Dag, if that’s not a confidential model I’d be happy to try on my end and see what happens…