QGIS installation issue: "got 3221225786 as return code"


I’ve tried to connect Speckle to QGIS on 2 separate Windows 10 machines, using the current “default” install from both programs. Therefore I have:

QGIS: 3.36.1
Speckle Connector: 2.18.1

I can install the QGIS plugin using the Speckle Manager, but when I click the plugin within QGIS to activate it, I get an error.

I have tried a number of different ways to install the Speckle plugin including from within QGIS by selecting the Speckle plugin and downloading and installing / copying the unzipped zip file and placing in the appropriate plugin directory - all with similar problems.

When clicking the tickbox to activate, a cmd window opens and hangs. When that window is eventually closed, an error page from QGIS displays. I have copied the contents of that page in the QGIS - Speckle - Error file attached.

I’ve added the Speckle logs, and the QGIS error

Thanks for the reporting! Current 2.18 release was tested with the latest LTR (3.28.15) and the latest available QGIS (3.34.3) at that time, but not later versions. Will have to test the compatibility, meanwhile you can try installing 3.28.15 and let us know if the error persists :raised_hands:

The concerning part of the log you attached is “Exception: Failed to install dependenices through pip, got 3221225786 as return code.”, looks like terminated by user error. In some cases that cmd window can freeze for no reason, so if you see it open, try to activate it and click Enter to “wake it up”. Also, make sure that QGIS is closed if you’re installing connector from Manager.

Hi Kateryna,

Thanks for getting back to me. I’m in Australia, so the timezones are not great.

I uninstalled 3.36 and installed 3.34 LTR. I had the same hangup issue during install (I did it from within QGIS). However, using your suggestion I highlighted the python cmd window and pressed enter (I had to do this about 20 times). Eventually the plugin seemed to be accepted by QGIS and the python cmds stopped popping up with “Successful plugin install” advised.

I then tried to open an existing QGIS project done in 3.36 in 3.34 and got an error about the QGIS version. So I uninstalled the Speckle plugin, uninstalled 3.34 and reinstalled 3.36. I then installed the Speckle plugin from within QGIS, and it installed with no issues.

I then tried to run Speckle and got the following dialog 1: Dependencies versioning error.
Clicking that link brought up dialog 2. I followed the instructions and the dependencies have been upgraded.

I have tried exporting a couple of streams and it appears to be working as advertised.

Yay. Thanks for your tips.

All the above is on my work computer, I need to do it again on my home computer tonight. I will try to install Speckle in 3.36 alone without downgrading to 3.34.

(not sure if the dialogs are actually going to upload …)

1 Like

Thanks for the detailed steps description, great to hear!