Problem with Streams using the Rhino Connector

Hello, I am having trouble using the Rhino Connector 2.5.1 with Rhino 7 (free trial version).

When I try to connect to a stream from Rhino, I get a “could not get streams” message (first image below), and when I try to manually search for the stream with its URL I get a “something went wrong” message (second image below). The stream works perfectly fine when I access it from a browser (third image below), and works perfectly fine with the Revit connector 2.5.2 for Revit 2022 (fourth image below)




I already tried restarting my computer, uninstalling the SpeckleManager, uninstalling the connectors, disconnecting from the account, but nothing seemed to work.

Is it because I use the free trial version of Rhino and is there anything I can do to fix this ?

Hi @Louis_Guillaume !

This is the first time we get this type of issue being reported, and both our connectors use the same code so it’s a bit weird, let’s try to debug it a bit:

  • is it the first time you use the Rhino connector or have you used it successfully before?
  • are you using a corporate laptop that might have specific firewall rules for Rhino?
  • maybe you can check if it has to do with this registry setting?

We don’t have evaluation versions of Rhino so cannot check if that’s the issue, so let us know how it goes with the above!

Hello,

  • It is indeed the first time I am using the connector and I haven’t managed to make it work yet
  • As far as I am aware, my laptop doesn’t treat Rhino differently than other softwares like Revit
  • I have tried the registry edit but without any conclusive results

Another thing I can think of, is the fact that I have VisualARQ 2 installed for Rhino, is there an incompatibility between the two ?

Can you please check if the grasshopper connector works?

If not, can you try pasting the following in a C# node and share the output?

 var ping = new System.Net.NetworkInformation.Ping();
 A = ping.Send("www.google.com").Status;

Hello,

The Grasshopper connector (2.5.2) does not seem to work either, as I am getting the same error of stream being inaccessible or missing.

As for the script, I copied it to the C# node and it seems to output “Success”, but as I am not used to using script, I am not sure I did it correctly.

1 Like

Thanks for this!
What happens if you replace “www.google.com” with “https://speckle.xyz/” in the c# component?

Changing the adress seems to create an error, and the output becomes null.

So it seems that the domain is blocked! :frowning: Are you able to check with your IT department maybe?

Hello,

I do not have an IT departement, I am currently studying architecture and using Speckle on a personal laptop. Also, if the domain is really blocked then the fact I am able to access it with the Revit connector is very weird. Is there a difference between the way Rhino uses Streams and the way Revit does ?

There is no difference between how our two connectors call our API, I thought there could have been some Firewall rules affecting Rhino. But since it’s your personal computer it’s probably not the case!
The only last thing I can think of is that it might be related to Rhino being an evaluation version…

Hi @Louis_Guillaume!

Are you using Windows 11 by any chance?

While I have no experience with Speckle on Windows 11, I have never managed to use Fologram on Rhino on Windows 11.

Fologram connects Rhino & GH with XR devices via the network, so needs similar OS permission to Speckle.

Just my 2 cents//

1 Like

Thanks for the suggestion @hhzz ! I have win 11 on my laptop and haven’t experienced this so far, but it’s definitely worth checking…

Hello,

I am currently using Speckle with Windows 10 so I think this is another dead end

1 Like