Problem updating parameter values when sending data from Grasshopper to Revit

Hello, I am working on a script that takes a Revit model and converts it to a Honeybee model so I can perform Daylight analysis and update parameters to send the results back to Revit. This script eliminates the need for building physics consultancies to have a Revit subscription.

I have encountered some issues while working on the final part of the script, specifically regarding sending back data. I am isolating the Room elements and extracting the parameter where I want to store the results. I have tried using both the applicationInternalName and the regular name, but they do not seem to update when I attempt to receive the elements in Revit.

It worked once on other parameters, but I am not sure what I did differently. That is where I encountered another problem. I used a Rhino and Revit file with millimeters as the unit, but Speckle applied a converter to the values, which transformed my “1” into “0.0328084” (the conversion value for centimeters to feet).

Could someone please help me solve this mystery?

Hey @670593
I’m not quite sure what you did differently either :slight_smile: but that unit conversion is unusual. Sharing sample files replicating the behaviour would help us to get to the bottom of this.

Hey, @670593,

Can you please try to feed a mm string in the ParameterUpdater node Units input port? We’re not automatically capturing the units of the model for that specific node I believe :slight_smile:

In regards to the failed update, do you see anything in the report?

Thanks for your inspiration. After some rigorous testing, I found that specifying “none” in the unit parameter does indeed work. Additionally, I observed that when I use ‘mm’ as input or leave it blank, the conversion rate is applied, so that seems like a bug. Thank you for your assistance, and I hope this information proves useful for the community. :slightly_smiling_face:

Awesome, I just remembered that this behaviour is documented here: Grasshopper | Speckle Docs