PowerbI Unable to Connect

Hello dear Specklers,

after the update of the PowerBI Connector to 2.17 the latest on your Github, we have the issue that

I have removed the data source settings, because I have thought maybe you changed something … did not help.

Before that and with the version from July it worked fine on our end. It does not work with speckle.xyz, app.speckle.systems and also not with our own deployment

Can you take a look or should I consider something?
Thanks for your help


Hi @AlexHofbeck,

I hope you are doing well. As far as I can tell, we haven’t made any changes recently that could have caused this issue. However, I have received similar reports from other users, and I’m unable to reproduce the issue on my end.

To help us identify and fix the issue, could you please provide us with the following details:

  • Your Power BI version
  • The version of your Power BI connector
  • Whether you can reproduce the issue on another device
  • Does it work with previous releases of the Power BI connector?

Providing us with this information will help us get to the root of the problem and find a solution. Let me know if you have any questions or concerns.

I have managed to reproduce the issue. We will investigate it further and i’ll update you when we have the fix.


Hi @gokermu,

thanks for taking a look at it! In case you need anything or want me to try something let me know!


Hey @AlexHofbeck ,

We have just released a hotfix. Can you please download it and confirm if it fixes the issue?

1 Like

Thanks for the update @gokermu. I tried it out … now with a different message

To answer your questions from above:

  • Your Power BI version = 2.123.742.0 64-bit (November 2023)
  • The version of your Power BI connector= your latest … and then 2.15 RC
  • Whether you can reproduce the issue on another device = did not try yet
  • Does it work with previous releases of the Power BI connector? = It seems also loading with older connectors does not work anymore … a few weeks ago it worked nicely.

Will try out on my end a bit where this is coming from

okay it seems to work again …

  • uninstalled PowerBI (November)
  • installed October version
  • used Speckle latest *.mez

Maybe November will work now too … but I don’t want to try that

1 Like

It’s great to hear that you were able to resolve your issue. Thank you for sharing the steps you took to fix it.

1 Like