Opacity/transparency not converted from Revit Material

Hi @SpeckleTeam, was wondering why my Revit objects didn’t show transparent in the viewer, then saw opacity is not sent from Revit. Known limitation?

Loving all the new features! Keep up the amazing work :raised_hands:

1 Like

Hi @Guus,
Thanks for the Report!

Currently, the way we convert materials from Revit → Speckle, is to use the colour and transparency properties that are set in the “Graphics” tab, and are what is shown in the “Shaded” view style.

If you were to enable the “Use Render Appearance” option (or set the transparency manually) under the “Graphics” Tab of your material. You should find it will have the correct transparency when sent to Speckle.

I’ll admit, it isn’t ideal. We have looked into what we can do about converting the render “appearance” (realistic mode) properties directly. But there are some technical limitations with Revit’s API that make this quite difficult.

If there is enough demand, It’s something that we could perhaps revisit.
I’d be happy to discuss what we can do to improve our Revit material conversion.


It would be great to be able to export data for basic daylighting simulations. For opaque materials reflectance value is needed and for transparent materials transmittance is needed.