Object has no attribute 'me'

did something change, i did not change anything on my end and now i get in the server.py line 68 that the object has no attribute .me’. i have checked everything im sending over and it all looks like a proper not Null object. here is the code i have

print( f"client = {self.client}")
print( f"me prop = {self.client.me}")
transport = ServerTransport(self.client, new_stream_id)

this is the result of the print

client = SpeckleClient( server: https://speckle.xyz, authenticated: True )
me prop = {‘token’: ‘----properly formated token i hid for the forum—’}


yes the order of the two inputs to the server transport has changed so you either need to provide them as kwargs or reverse the order. the object should be initialised as either:

  • ServerTransport(STREAM_ID, client)
  • ServerTransport(client=client, stream_id=STREAM_ID)

ok thanks that worked. obviously, other things changed too

2022-02-17 15:29:18 [Error] [specklepy.transports.server.batch_sender] […\batch_sender.py:86] Error sending batch of objects to server: SpeckleException: Invalid credentials - cannot send objects to server https://speckle.xyz

not sure what that could be without more information or code. the error is telling you your server transport is not authorised to send to that stream. do you definitely have write access to the stream? is everything properly authenticated with the correct account / token? can you use the server transport to receive?

ok i made a new token and it worked

great! glad you worked it out

1 Like