Not having required priviliges

Hi guys,

I’ve been playing around with the plugin a bit, and I’m stuck somewhere, hope you guys can help.

When i try to deselect the “Specify by Object Id” option it gives this errors :

[2023.06.23-10.55.19:574][667]LogSpeckle: Warning: UReceiveSelectionComponent::UpdateStreams: failed - You do not have the required privileges.
[2023.06.23-10.55.19:574][667]LogSpeckle: Warning: UReceiveSelectionComponent::UpdateStreams: You do not have the required privileges.

Here’s a screenshot:

(I tried a few times which is why there are multiple errors)

I’ve also tried to create a new auth token with all the permissions I could click but no result.

Thanks in advance for reading and helping.

Hi @eugeneida

Firstly, I just want to double check that you are generating your auth token correctly.
Please could you follow this guide for setting up the unreal connector with an auth token. It’s important that you include scopes.
And take care to copy paste the token with out any trailing spaces or additional characters. Additionally, please check the server url is correct and must match the server you are generating the auth token from.

Recently, we have identified a bug where not specifying an authtoken was preventing receives of even public streams. Which we have already pushed a fix for (available now on github, but will take several days to reach the Epic marketplace)

I don’t think this is the issue you are running into, but if you can’t find success, then it might be a good idea to install latest version manually (see Unreal | Speckle Docs) or waiting for the update to reach the epic marketplace (again, may take days)

Please let me know if you get stuck, and I’m happy to investigate further,

Also, I just want to double check.
Are you able to receive through specifying an streamId + objectId?

Additionally, could you check if you can receive private streams this way.

Hi Jedd,

Thanks for the response, I’ve been away, and just got back.

I’ll answer your last question first, which is that, yes, I can receive objects if i specify streamId + objectId.
Which is what led me to post in the first place. It would seem like the auth token is not the issue, yet I am getting these errors.

But just in case it was a question, I always do this when copying from websites to remove formatting, so I have them pasted in notepad, and yes they do not have spaces at either end.
Screenshot 2023-06-27 140931

I am installing it via building the plugin from code. I am assured I have the latest since my own debug logs are showing up also (as i was doing some tracing myself to understand if there were issues on my end).
Screenshot 2023-06-27 141545
(uncommited changes are my UE_LOGs)

in case you were wondering.
I also manually built them as well, but they show my logs so I don’t think I didnt build them right.

So currently that is the reason for this post. I am using as you can see in the previous post, Unreal 5.2

I am still stuck, so hopefully you have some idea.

Hi @eugeneida

I’ve just pushed some changes to main on github.
If possible, please could you follow our instructions to install the plugin through git to test if these latest changes fix your authentication problems.

Otherwise, I aim to get these changes on the epic marketplace over the next week or so.

Hi Jedd,

I’ve updated it and built it through git. I added another line of logs, to make sure i got the build correct because this is my output (first line is my log line)

Again, I’ll just screenshot my repo:

So I’m still getting the error.

I realise I was unclear in the first post, but you could reproduce this by unchecking the “Specify by Object Id” in the SpeckleUnrealManager Actor in the second screenshot in the original post.

If you need any more logs, I can try to provide them for you.

Thanks for your help so far.

Thanks for your patience,

I’m struggling to reproduce this issue on my end, I’ve tested now with accounts from a few different speckle servers.

Are you having problems with any other connectors authenticating?

Are you running a corporate VPN or firewall that might be blocking web requests to our servers?
Are you able to test from another network or machine?

If you wouldn’t mind running a quick test on your end, I really want to get to the bottom of this, not only to unblock you, but to prevent these problems from affecting other users as well.

I have created a simple blueprint that I’d like you to test.

You should be able to copy paste the BP from this link into a Level Blueprint. (or recreate from the screenshot below)

Just make sure it’s hooked up to the “Begin Play” event on the level BP.

After running the Level from the editor, it should print to console either all your streams, or an error message.

Here’s my output (unfortunately, I’ve have to censor some of my streams)

1 Like

Hello Jedd,

Thanks for your continued support. No worries, I suspected you might have issues with reproduction.

There is no VPN or firewall. As previously shown, I can pull if and only if i specify stream id and object id, and speckle totally works. I am currently unable to test on another machine currently.

As requested, here is the log:

Edit: I realised I did not actually show this, but here is the log from using the default speckle manager provided to do so:

speckle unreal log.txt (824.2 KB)

I am not sure if that is helpful.

Just for completeness, here is a screenshot of what you have provided in my level BP.

Do tell me if you need any further information, logs or tests.