Not able to install the @speckle/shared

➤ YN0000: [@speckle/frontend]: Plugin: vite:import-analysis
➤ YN0000: [@speckle/frontend]: File: C:/Users/DELL/Desktop/3d/speckle-server/packages/frontend/src/plugins/authHelpers.js:8:47
➤ YN0000: [@speckle/frontend]: 6 | import { has } from ‘lodash’
➤ YN0000: [@speckle/frontend]: 7 | import { deletePostAuthRedirect } from ‘@/main/lib/auth/utils/postAuthRedirectManager’
➤ YN0000: [@speckle/frontend]: 8 | import { resolveMixpanelUserId } from ‘@speckle/shared’
➤ YN0000: [@speckle/frontend]: | ^
➤ YN0000: [@speckle/frontend]: 9 | import { convertThrowIntoFetchResult } from ‘@/main/lib/common/apollo/helpers/apolloOperationHelper’
➤ YN0000: [@speckle/frontend]: 10 |
➤ YN0000: [@speckle/frontend]: at formatError (file:///C:/Users/DELL/Desktop/3d/speckle-server/node_modules/vite/dist/node/chunks/dep-e8f070e8.js:42645:46)
➤ YN0000: [@speckle/frontend]: at TransformContext.error (file:///C:/Users/DELL/Desktop/3d/speckle-server/node_modules/vite/dist/node/chunks/dep-e8f070e8.js:42641:19)
➤ YN0000: [@speckle/frontend]: at normalizeUrl (file:///C:/Users/DELL/Desktop/3d/speckle-server/node_modules/vite/dist/node/chunks/dep-e8f070e8.js:40508:33)
➤ YN0000: [@speckle/frontend]: at async file:///C:/Users/DELL/Desktop/3d/speckle-server/node_modules/vite/dist/node/chunks/dep-e8f070e8.js:40651:47
➤ YN0000: [@speckle/frontend]: at async Promise.all (index 7)
➤ YN0000: [@speckle/frontend]: at async TransformContext.transform (file:///C:/Users/DELL/Desktop/3d/speckle-server/node_modules/vite/dist/node/chunks/dep-e8f070e8.js:40577:13)
➤ YN0000: [@speckle/frontend]: at async Object.transform (file:///C:/Users/DELL/Desktop/3d/speckle-server/node_modules/vite/dist/node/chunks/dep-e8f070e8.js:42919:30)
➤ YN0000: [@speckle/frontend]: at async loadAndTransform (file:///C:/Users/DELL/Desktop/3d/speckle-server/node_modules/vite/dist/node/chunks/dep-e8f070e8.js:53385:29)
➤ YN0000: [@speckle/frontend]: Failed to resolve import “@speckle/shared” from “src\helpers\mainConstants.ts”. Does the file exist?
➤ YN0000: [@speckle/frontend]: Failed to resolve import “@speckle/shared” from “src\main\lib\auth\utils\postAuthRedirectManager.ts”. Does the file exist?
➤ YN0000: [@speckle/frontend]: Failed to resolve import “@speckle/shared” from “src\helpers\mainConstants.ts”. Does the file exist?

1 Like

Hi @sandeep, you probably need to run yarn build:public from the root of the repo. For more context, what are you trying to do, and what steps got you those errors?

1 Like

i have unistalled node_modules and again installed it back now its solved

but when i run the frontend in the local say localhost:3000 i m getting this error
the UI is not loading

➤ YN0000: [@speckle/frontend-2]: [0] ERROR Failed to resolve import “fsevents” from “node_modules.vite\deps\chunk-2XWN4UZ6.js?v=01302422”. Does the file exist?

hii @dimitrie
soo while running the frontend in the localhost:3000 i m not able to load the UI in the browser i m getting stuck in the splash screen only and i m getting this error in the console which is there in the image
can you please help me to get solve this as soon as possible.

Hey @sandeep

I think dimitrie’s tip solved the original problem of @speckle/shared being missing. The other problem with the fsevents error makes me think that you’re trying to run an old version of speckle, because we fixed it a few weeks back.

Can you share the following info?

  • speckle-server repo commit & branch that you’re trying to run
  • OS & Version
  • Node version
  • Yarn version
  • The errors in your browser console when the app doesn’t load

I will say that no one internally runs speckle-server on Windows directly, everyone who has a Windows machine runs it in WSL2. So it is theoretically possible (altho I doubt it) that the issue arises from you running it on Windows directly.


P.S. Make sure you follow our guide for setting up the local dev env Local development environment | Speckle Docs


  1. have the latest changes in system.
  2. Windows 11
  3. node version v18.16.0
  4. yarn version 3.2.0
  5. No errors just got request completed message.

For redis, someone in the forum suggested to use this (5.7 MB)

I have extracted it and open the redis application as below,

So I checked in task manager, WSL is running here.


You don’t need to manually download and run any redis servers, if you follow the guide it’s going to set all of that up using docker (the yarn dev:docker:up command).

The CLI output looks fine, but if there’s an issue when the page is opened up in the browser you should share your browser console output as well.

Regarding WSL - it may be running, but you aren’t using it, from your screenshots it looks like you’re running everything in Windows, not the Linux subsystem.