No speckle window

Hello team, when I click on the blue box in SketchUp, nothing happens. It works fine in Revit, so it should be correctly installed.

1 Like

Hi @Martin_Josefsson ,

Welcome to the community! Feel free to Introduce yourself :person_gesturing_ok: to the community if you want to! :grinning:

It seems like something isn’t quite right. Could you provide me with a bit more information?

  • Are you using a work laptop or a personal one?

  • Do you have any firewalls in place?

  • Have you tried running it on another device?

  • If you are able to, could you please open the terminal before running the Speckle connector and share a screenshot of it after running it? This would help us better understand what might be going on.


Hi, I have the same issue! Speckle SketchUp 2.17 doesn’t open!
I have tried previous versions with no luck with my SketchUp2022

I use a laptop, no firewalls and no other device to try.

Here’s Ruby warning:

Error: #<JSON::ParserError: 783: unexpected token at ', "fe2":false'>
C:/Program Files/SketchUp/SketchUp 2022/Tools/RubyStdLib/json/common.rb:156:in `parse'
C:/Program Files/SketchUp/SketchUp 2022/Tools/RubyStdLib/json/common.rb:156:in `parse'
C:/Users/mkhalil/AppData/Roaming/SketchUp/SketchUp 2022/SketchUp/Plugins/speckle_connector/src/preferences/preferences.rb:37:in `data_complete?'
C:/Users/mkhalil/AppData/Roaming/SketchUp/SketchUp 2022/SketchUp/Plugins/speckle_connector/src/preferences/preferences.rb:49:in `validate_user_preferences'
C:/Users/mkhalil/AppData/Roaming/SketchUp/SketchUp 2022/SketchUp/Plugins/speckle_connector/src/preferences/preferences.rb:22:in `read_preferences'
C:/Users/mkhalil/AppData/Roaming/SketchUp/SketchUp 2022/SketchUp/Plugins/speckle_connector/src/actions/initialize_speckle.rb:23:in `update_state'
C:/Users/mkhalil/AppData/Roaming/SketchUp/SketchUp 2022/SketchUp/Plugins/speckle_connector/src/app/speckle_connector_app.rb:51:in `update_state!'
C:/Users/mkhalil/AppData/Roaming/SketchUp/SketchUp 2022/SketchUp/Plugins/speckle_connector/src/commands/initialize_speckle.rb:37:in `initialize_speckle'
C:/Users/mkhalil/AppData/Roaming/SketchUp/SketchUp 2022/SketchUp/Plugins/speckle_connector/src/commands/initialize_speckle.rb:28:in `_run'
C:/Users/mkhalil/AppData/Roaming/SketchUp/SketchUp 2022/SketchUp/Plugins/speckle_connector/src/commands/command.rb:22:in `block in run'
C:/Users/mkhalil/AppData/Roaming/SketchUp/SketchUp 2022/SketchUp/Plugins/speckle_connector/src/commands/command.rb:33:in `with_observers_disabled'
C:/Users/mkhalil/AppData/Roaming/SketchUp/SketchUp 2022/SketchUp/Plugins/speckle_connector/src/commands/command.rb:21:in `run'
C:/Users/mkhalil/AppData/Roaming/SketchUp/SketchUp 2022/SketchUp/Plugins/speckle_connector/src/commands/menu_command_handler.rb:12:in `block in sketchup_command'

Hi @rashadco2005,

Seems like we faced with edge case with you, and I have fixed the issue thanks to your report here. Can you try with 2.17.1 which is just released as hotfix?

Hope this will fix your issue. Otherwise will be here to help more.



The hotfix worked. Thank you.

1 Like

Hey @Martin_Josefsson ,

Did you try Oguzhan’s solution? Let us know if it didn’t work.