No data in a stream sent from Revit2020

Hello, I am working at Hong Kong Arup and start using Speckle for Updating Revit in GH.

I sent a stream from Revit and checked the stream on webpage. However, no data is saved in the stream and I cannot see anything when I received the stream in GH.

I downloaded “Speckle.ext” from the link below.
(Release Speckle-v1.8.31.336 · speckleworks/SpeckleInstaller · GitHub)

When I run Grasshopper, I have the warning message as attached.

I searched old posts related to “reinstallation” and "no file under “SpeckleKits”. I tried reinstallation and my “SpeckleKits” folder has files as attached.

Please can anyone help to resolve my two issues, data in sent stream 2.error message when running GH?

Thank you.


It was my mistake. I forgot to click the “upload” button and I uploaded unsuitable elements. If any beginner has the same issue, I hope this post is helpful.


Thanks for getting back with a solution David!
Yes, that old Revit UI isn’t very intiutive, the new one we are releasing with v2 is much more clear :slight_smile: