No converter was provided

Hi all.

I updated the Grasshopper plugin yesterday, and now I have tihs error:

How to enable conversions?

It seems to have one? image

Version I’m running currently is: 2.2.7-beta

1 Like

Hmm… it’s been a while since I’ve bumped into this one!

Usually this means that the installation went wrong in some way, although judging by the Objects kit being present, I’d say you may be missing the ConverterRhino6.dll in the %appdata%/Speckle/Kits/Objects/ folder.

Could you check if that is the case?
Could you also try uninstalling the grasshopper (and rhino!) connectors and reinstalling them again?

Thanks for reporting this :wink:

Thanks for quick response Alan!

The Converter is in the folder:

I’ll check uninstalling and reinstalling.

Reinstalling didn’t work… same error.

Weird, I tried a full reinstall on my clean machine and didn’t have any problems.

What other connectors do you have installed? Also, could you send me your SUUID?

No other connectors installed I think. What is my SUUID?

That happened to me once. What I did to fix was:

  1. Uninstall the connector through Speckle Manager.
  2. Went to %appdata%/Kits/Objects and deleted the Objects and Objects.Converter.Rhino/Grasshopper dlls.
  3. Reinstalled the connector through Speckle Manager.
2 Likes

And here’s how to get your SUUID: Speckle Manager | Speckle Docs

Thanks vwb!

However, when I did this, all the kits are gone.

image

Here my SUUID: 0b901b88-69b3-4b01-a84d-d99cdab936a3

So… just to be 100% clear. You removed the dlls, re-installed the connector and now you get this? What are the contents of your %appdata%/speckle/kits/objects folder after doing so?

Yes. I removed the dlls. Re-installed it and now i get this.

These are the contents now:

image

1 Like

Maybe you could also try downgrading to the latest stable: Speckle Manager | Speckle Docs

Interesting…could those dll's be blocked by any chance?

I’m kinda running out of ideas already… let’s arrange a quick call to look into it if you have time sometime today or monday :wink:

Hi Alan!

Thanks! I was a bit busy the last few days. Dll’s are not blocked. I can still try downgrading. Let me test that, otherwise we can plan a call.

1 Like

This helped! :slight_smile: Thanks!

2 Likes