Multiple models merged in power BI stop working with visualizations

Howdido speckle community!

I have merged multiple models with the same customized parameters from Revit and when adding visualizations within Power BI (e.g., slicers) and clicking on them more than 3 times the speckle visual stops working. Does anyone have encountered this same issue?

1 Like

Hi @alan_avila,

Welcome to the community! Feel free to Introduce yourself :person_gesturing_ok: to the community if you want to! :smiley:

Can you please tell me which version of the PowerBI connector you are using?

I recommend having a look at the following video tutorial if you haven’t done so already.

Thank you

Thank you for your reply.
I already followed the workflow from the tutorial.
I’m using the last update 2.19 for both revit 2025 and power bi. I also tried two approaches, the first merging the speckle queries of the models without extracting parameters, and then connecting the extra data with separate queries. And the second extracting all the parameters in one query and then extracting the parameters. But both of them are not working correctly.

Hey @alan_avila,

Sorry about that. Your problem might be related to the 2.19 version because we had similar issues with other users. Before doing anything else, make sure to set the Tooltip info input and try again. If this doesn’t work, then please uninstall the 2.19 version and install the PowerBI connector 2.18 version from GitHub.

Let me know how it goes. Thank you.

1 Like

Hi Nikos!

I have tried with both versions 2.18 and 2.19 and it still is not working properly. I attached a short video so it’s clearer what i’m talking about. I’ll really appreciate your assistance with this issue.


Thank you in advance.

Hey Alan,

Thanks for sharing the video, it looks odd tbh. As I mentioned in my previous comment can you set the Toolip Data input and try again? We have noticed sometimes a weird behaviour when the Tooltip input is missing. Keep the 2.18 version.

If you still have a problem, you can send me your powerBI file in private message and we can investigate further.

Thanks

1 Like

Hi @alan_avila,

I investigated the issue and was able to reproduce it. It appears that the problem occurs only when merging multiple models in a single 3D visual. Until we implement a fix, you can send them together as a single model from Revit as a workaround. You can link one of the models and ensure that you enable the “Send Linked Models” option from the Advanced Settings dialog.

Thank you for reporting this.

1 Like