Manager installation for GH + Rhino

hihih :wave:

Was wondering if anyone else has been experiencing issues with installing the gh +rhino connector through the manager? Specifically them not showing up in gh or rhino… I was doing some troubleshooting for a previous post when I was noticing the connectors weren’t showing up. I moved back to my local machine and tried the same process and got the same result. I poked around the typical component folders and plugin spaces didn’t find much. AppData\Roaming\Grasshopper\Libraries is empty but AppData\Roaming\McNeel\Rhinoceros\7.0\Plug-ins\SpeckleRhino2 was in place. However, I can’t seem to launch speckle from rhino


In the manager they show up as installed.


One last note - I installed grasshopper first and it populated rhino with the plugin as well.

Hey David,

Since a while we’re packaging GH and Rhino together, that means that when you install GH also Rhino is installed and vice versa.

On your machine, you should see them both in (if installed for the local user only):
%appdata%\McNeel\Rhinoceros\6.0\Plug-ins\SpeckleRhino2 (8dd5f30b-a13d-4a24-abdc-3e05c8c87143)\

It is maybe possible that you local environment is polluted with versions that you debugged locally?

I’d suggest as always, a good clean up and reinstall if this is the case!

I had the same earlier this week. One of the installers didn’t go through. Can’t remember which one :smiley: but then I tried the other and then it worked. :stuck_out_tongue:

1 Like

I did swing through and pull out any previous versions I was working with and updated the manager as well. But I’ll give it another look tomorrow, probably something hanging out in there that I miseed

@teocomi went back and tried this process again. Didn’t find any lingering plugin files, debug versions, or any other garbage like that but I was able to get the connector working by installing the rhino plugin first before the grasshopper connector.

When I tried installing the grasshopper connector individually, it would should up as installed in the manager but nothing in the grasshopper window

w/o rhino connector installed

w/ rhino connector installed

1 Like

I found what’s going on, thanks for digging into it!!
There’s actually a problem in the GH installer, will be fixed in 2.10.